summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-12-06 15:49:12 -0500
committerMike Gilbert <floppym@gentoo.org>2020-12-06 15:50:45 -0500
commit5683b0da671c86041cec2db8c70fc2c9a0a100ce (patch)
tree421b7dd630fa40bb00d986733577b223e9172f11 /sys-power/cpupower
parentdev-python/paramiko: Remove old (diff)
downloadgentoo-5683b0da671c86041cec2db8c70fc2c9a0a100ce.tar.gz
gentoo-5683b0da671c86041cec2db8c70fc2c9a0a100ce.tar.bz2
gentoo-5683b0da671c86041cec2db8c70fc2c9a0a100ce.zip
sys-power/cpupower: remove old
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-power/cpupower')
-rw-r--r--sys-power/cpupower/Manifest1
-rw-r--r--sys-power/cpupower/cpupower-4.13.0.ebuild69
-rw-r--r--sys-power/cpupower/files/cflags-strip.patch18
3 files changed, 0 insertions, 88 deletions
diff --git a/sys-power/cpupower/Manifest b/sys-power/cpupower/Manifest
index 778c7cda1ae7..f23592fdec5f 100644
--- a/sys-power/cpupower/Manifest
+++ b/sys-power/cpupower/Manifest
@@ -1,2 +1 @@
-DIST cpupower-4.13.0.tar.xz 67812 BLAKE2B 3b94b18bb57b0499a96d57ca26a48f528bf993e0f1ed7eb6d2949c879de8796501629bd0978946eae925d86dd3204a1cab0c99f1c3a8b51731dfbdb61451e990 SHA512 5e7095e2741eae920a097864926931afb2656e492b504f203c40c24ddc5aee5014c7689b220225171b5ea10c69b70774fb2a979d05ea56ef1fa063f3097626c7
DIST linux-5.4.tar.xz 109441440 BLAKE2B 193bc4a3147e147d5529956164ec4912fad5d5c6fb07f909ff1056e57235834173194afc686993ccd785c1ff15804de0961b625f3008cca0e27493efc8f27b13 SHA512 9f60f77e8ab972b9438ac648bed17551c8491d6585a5e85f694b2eaa4c623fbc61eb18419b2656b6795eac5deec0edaa04547fc6723fbda52256bd7f3486898f
diff --git a/sys-power/cpupower/cpupower-4.13.0.ebuild b/sys-power/cpupower/cpupower-4.13.0.ebuild
deleted file mode 100644
index 28ce7238b738..000000000000
--- a/sys-power/cpupower/cpupower-4.13.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2013-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# eutils: strip-linguas
-inherit eutils systemd toolchain-funcs
-
-DESCRIPTION="Shows and sets processor power related values"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
-IUSE="nls"
-
-# File collision w/ headers of the deprecated cpufrequtils
-RDEPEND="sys-apps/pciutils
- !<sys-apps/linux-misc-apps-3.6-r2
- !sys-power/cpufrequtils"
-DEPEND="${RDEPEND}
- virtual/os-headers
- nls? ( sys-devel/gettext )"
-
-PATCHES=(
- "${FILESDIR}"/cflags-strip.patch
-)
-
-src_configure() {
- export bindir="${EPREFIX}/usr/bin"
- export sbindir="${EPREFIX}/usr/sbin"
- export mandir="${EPREFIX}/usr/share/man"
- export includedir="${EPREFIX}/usr/include"
- export libdir="${EPREFIX}/usr/$(get_libdir)"
- export localedir="${EPREFIX}/usr/share/locale"
- export docdir="${EPREFIX}/usr/share/doc/${PF}"
- export confdir="${EPREFIX}/etc"
- export V=1
- export NLS=$(usex nls true false)
-}
-
-src_compile() {
- myemakeargs=(
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- LD="$(tc-getCC)"
- VERSION=${PV}
- )
-
- if [[ -n ${LINGUAS+set} ]]; then
- strip-linguas -i po
- myemakeargs+=( LANGUAGES="${LINGUAS}" )
- fi
-
- emake "${myemakeargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" "${myemakeargs[@]}" install
- doheader lib/cpupower.h
- dodoc README ToDo
-
- newconfd "${FILESDIR}"/conf.d-r2 cpupower
- newinitd "${FILESDIR}"/init.d-r4 cpupower
-
- systemd_dounit "${FILESDIR}"/cpupower-frequency-set.service
- systemd_install_serviced "${FILESDIR}"/cpupower-frequency-set.service.conf
-}
diff --git a/sys-power/cpupower/files/cflags-strip.patch b/sys-power/cpupower/files/cflags-strip.patch
deleted file mode 100644
index 6e70fdf38b1c..000000000000
--- a/sys-power/cpupower/files/cflags-strip.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -180,14 +180,7 @@
- endif
- export QUIET ECHO
-
--# if DEBUG is enabled, then we do not strip or optimize
--ifeq ($(strip $(DEBUG)),true)
-- CFLAGS += -O1 -g -DDEBUG
-- STRIPCMD = /bin/true -Since_we_are_debugging
--else
-- CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer
-- STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
--endif
-+STRIPCMD = true
-
-
- # the actual make rules