summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-10-21 22:30:24 -0400
committerRick Farina <zerochaos@gentoo.org>2019-10-21 22:30:39 -0400
commit0f6dddd1d0f658bf6c4331382eec0d02f66192b2 (patch)
treeaef40c67ecdb5dcbf95304af0255995ec0869a5b /sys-power
parentnet-dns/bind-tools: Fix COMMON_DEPEND reference in RDEPEND (diff)
downloadgentoo-0f6dddd1d0f658bf6c4331382eec0d02f66192b2.tar.gz
gentoo-0f6dddd1d0f658bf6c4331382eec0d02f66192b2.tar.bz2
gentoo-0f6dddd1d0f658bf6c4331382eec0d02f66192b2.zip
sys-power/thermald: fix build failure on newer gcc
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/files/thermald-1.9-size_t-format.patch44
-rw-r--r--sys-power/thermald/thermald-1.9.ebuild1
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-power/thermald/files/thermald-1.9-size_t-format.patch b/sys-power/thermald/files/thermald-1.9-size_t-format.patch
new file mode 100644
index 000000000000..324b3b97f79a
--- /dev/null
+++ b/sys-power/thermald/files/thermald-1.9-size_t-format.patch
@@ -0,0 +1,44 @@
+From dcdaf523393a6e7c07b5a510c573223722b0289b Mon Sep 17 00:00:00 2001
+From: Anuj Mittal <anuj.mittal@intel.com>
+Date: Thu, 1 Aug 2019 08:15:52 +0800
+Subject: [PATCH] Use correct format specifier for size_t
+
+%zu instead of %lu, otherwise on 32 bit:
+
+| In file included from ../git/src/thd_common.h:27,
+| from ../git/src/thd_zone.h:30,
+| from ../git/src/thd_zone.cpp:34:
+| ../git/src/thd_zone.cpp: In member function 'void cthd_zone::update_highest_trip_temp(cthd_trip_point&)':
+| ../git/src/thd_zone.cpp:322:16: error: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'std::vector<cthd_trip_point>::size_type' {aka 'unsigned int'} [-Werror=format=]
+| 322 | thd_log_info("trip_points.size():%lu\n", trip_points.size());
+| | ^~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~
+| | |
+| | std::vector<cthd_trip_point>::size_type {aka unsigned int}
+| ../git/src/thermald.h:82:57: note: in definition of macro 'thd_log_info'
+| 82 | #define thd_log_info(...) g_log(NULL, G_LOG_LEVEL_INFO, __VA_ARGS__)
+| | ^~~~~~~~~~~
+| ../git/src/thd_zone.cpp:322:38: note: format string is defined here
+| 322 | thd_log_info("trip_points.size():%lu\n", trip_points.size());
+| | ~~^
+| | |
+| | long unsigned int
+| | %u
+
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ src/thd_zone.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/thd_zone.cpp b/src/thd_zone.cpp
+index dd485d9..eb81d61 100644
+--- a/src/thd_zone.cpp
++++ b/src/thd_zone.cpp
+@@ -319,7 +319,7 @@ void cthd_zone::add_trip(cthd_trip_point &trip) {
+ void cthd_zone::update_highest_trip_temp(cthd_trip_point &trip)
+ {
+ if (trip_points.size()) {
+- thd_log_info("trip_points.size():%lu\n", trip_points.size());
++ thd_log_info("trip_points.size():%zu\n", trip_points.size());
+ for (unsigned int j = trip_points.size() - 1;; --j) {
+ if (trip_points[j].get_trip_type() == trip.get_trip_type()) {
+ thd_log_info("updating existing trip temp \n");
diff --git a/sys-power/thermald/thermald-1.9.ebuild b/sys-power/thermald/thermald-1.9.ebuild
index 33bfe3ff73b1..9eb5e8b92494 100644
--- a/sys-power/thermald/thermald-1.9.ebuild
+++ b/sys-power/thermald/thermald-1.9.ebuild
@@ -26,6 +26,7 @@ S=${WORKDIR}/thermal_daemon-${PV}
DOCS=( thermal_daemon_usage.txt README.txt )
src_prepare() {
+ eapply "${FILESDIR}/${P}-size_t-format.patch"
default
eautoreconf
}