summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 15:48:00 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 15:48:00 +0100
commit3f4aea9d7d862dc542123802e50c1a4781a7c5c3 (patch)
tree1425f1a2d43837fb7358f0d7b4b9e3aa090c2549 /sys-power
parentnet-wireless/dump1090: Sync live ebuild (diff)
downloadgentoo-3f4aea9d7d862dc542123802e50c1a4781a7c5c3.tar.gz
gentoo-3f4aea9d7d862dc542123802e50c1a4781a7c5c3.tar.bz2
gentoo-3f4aea9d7d862dc542123802e50c1a4781a7c5c3.zip
sys-power/athcool: Port to EAPI 7
Closes: https://bugs.gentoo.org/725976 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/athcool/athcool-0.3.12.ebuild11
-rw-r--r--sys-power/athcool/files/athcool-0.3.12-build.patch (renamed from sys-power/athcool/files/athcool-0.3.11-build.patch)0
-rw-r--r--sys-power/athcool/files/athcool-0.3.12-fno-common.patch13
3 files changed, 19 insertions, 5 deletions
diff --git a/sys-power/athcool/athcool-0.3.12.ebuild b/sys-power/athcool/athcool-0.3.12.ebuild
index bd826f25b0f5..f1516378cdd8 100644
--- a/sys-power/athcool/athcool-0.3.12.ebuild
+++ b/sys-power/athcool/athcool-0.3.12.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -12,12 +12,13 @@ SRC_URI="http://members.jcom.home.ne.jp/jacobi/linux/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* x86"
-IUSE=""
DEPEND="sys-apps/pciutils"
-RDEPEND=""
-PATCHES=( "${FILESDIR}"/${PN}-0.3.11-build.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_configure() {
tc-export CC
diff --git a/sys-power/athcool/files/athcool-0.3.11-build.patch b/sys-power/athcool/files/athcool-0.3.12-build.patch
index bcf3a3054142..bcf3a3054142 100644
--- a/sys-power/athcool/files/athcool-0.3.11-build.patch
+++ b/sys-power/athcool/files/athcool-0.3.12-build.patch
diff --git a/sys-power/athcool/files/athcool-0.3.12-fno-common.patch b/sys-power/athcool/files/athcool-0.3.12-fno-common.patch
new file mode 100644
index 000000000000..7fbbea95e9e8
--- /dev/null
+++ b/sys-power/athcool/files/athcool-0.3.12-fno-common.patch
@@ -0,0 +1,13 @@
+--- a/scanpci.c
++++ b/scanpci.c
+@@ -11,8 +11,8 @@
+
+ #define die printf
+
+-struct pci_filter filter;
+-struct pci_access *pacc;
++extern struct pci_filter filter;
++extern struct pci_access *pacc;
+ static int show_hex = 0;
+
+ static struct device *scan_device( struct pci_dev *p )