summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-28 13:38:05 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-29 11:02:58 -0400
commit84949d8cc910c2ed1d14838067ad8acd9a782d6e (patch)
treed6ba833419e5968dad70f0f27b081c237ac2f9b2 /sys-power
parentkde-apps/pimcommon: Add missing dependency (diff)
downloadgentoo-84949d8cc910c2ed1d14838067ad8acd9a782d6e.tar.gz
gentoo-84949d8cc910c2ed1d14838067ad8acd9a782d6e.tar.bz2
gentoo-84949d8cc910c2ed1d14838067ad8acd9a782d6e.zip
sys-power/power-profiles-daemon: Version bump to 0.13
Signed-off-by: Matt Turner <mattst88@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/30797 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/power-profiles-daemon/Manifest1
-rw-r--r--sys-power/power-profiles-daemon/power-profiles-daemon-0.13.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sys-power/power-profiles-daemon/Manifest b/sys-power/power-profiles-daemon/Manifest
index d954634f4b92..66b5b0a475fa 100644
--- a/sys-power/power-profiles-daemon/Manifest
+++ b/sys-power/power-profiles-daemon/Manifest
@@ -1 +1,2 @@
DIST power-profiles-daemon-0.12.tar.bz2 47846 BLAKE2B 7fb10e78c5ab6da32a4b460c8046e510c66bb0d31ca4c7e14db5772c547c420be078f3086b6b98e70063fed0924e783f5b26580a97e0898474040a2724b87f91 SHA512 d34e51deeed13ed307b9efac08336ce36879d7deeac5af803207d1c69f641993a509d96e149c3f150c5d20437867f3cbc6502fce6f63e08f0b23f23c7f90d948
+DIST power-profiles-daemon-0.13.tar.bz2 49079 BLAKE2B 2a7c81b0ac8b4ac4a9805f5dcd722959ff0abe736782eba7678f49eb3c5790d59b2bcc35577733aaae9fc8baa76a65ca9a973ac9f0d9154061c3af86abe0e65d SHA512 dab0c44968480a2f5ae2074f07a48d901970c9b3b3ec104d14108615f85b1eb0f9f3e1b5f0ff766659e4d76b243da2cd4c025cd81b992b7149fb671e103a7d6b
diff --git a/sys-power/power-profiles-daemon/power-profiles-daemon-0.13.ebuild b/sys-power/power-profiles-daemon/power-profiles-daemon-0.13.ebuild
new file mode 100644
index 000000000000..86f286cd8fff
--- /dev/null
+++ b/sys-power/power-profiles-daemon/power-profiles-daemon-0.13.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-single-r1 systemd
+
+DESCRIPTION="Makes power profiles handling available over D-Bus"
+HOMEPAGE="https://gitlab.freedesktop.org/hadess/power-profiles-daemon/"
+SRC_URI="https://gitlab.freedesktop.org/hadess/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk-doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ dev-libs/glib:2
+ >=dev-libs/libgudev-234
+ >=sys-auth/polkit-0.114
+ sys-power/upower
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? (
+ dev-util/gi-docgen
+ dev-util/gtk-doc
+ )
+ test? (
+ dev-util/umockdev
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test; then
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+ else
+ python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/powerprofilesctl
+ newinitd "${FILESDIR}/power-profiles-daemon.initd" power-profiles-daemon
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if systemd_is_booted; then
+ elog "You need to enable the service:"
+ elog "# systemctl enable ${PN}"
+ else
+ elog "# rc-update add ${PN} default"
+ fi
+ fi
+}