summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-12-06 13:45:32 +0100
committerPacho Ramos <pacho@gentoo.org>2020-12-06 13:45:47 +0100
commit95c7d51f1b36bc2d23bc94eef2fb46428fc90de8 (patch)
tree239546f7be8dace38630a8768c8a119ad713b2a6 /sys-power
parentsys-power/thermald: Don't use Werror (diff)
downloadgentoo-95c7d51f1b36bc2d23bc94eef2fb46428fc90de8.tar.gz
gentoo-95c7d51f1b36bc2d23bc94eef2fb46428fc90de8.tar.bz2
gentoo-95c7d51f1b36bc2d23bc94eef2fb46428fc90de8.zip
sys-power/thermald: Bump to 2.4.1
Closes: https://bugs.gentoo.org/757918 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.4.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index ad5d4188e16c..6a3bf0017e02 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-2.2.tar.gz 435659 BLAKE2B 500189b924594e5b1d68adc776b3ad0c1d531d4259c65dd77f9166648c9b4273c52e1f8222254ec6500b3d37e39deb4ec862443728d50e9be95dee8e43496645 SHA512 f2c691061436699aef5bb7d9681370306dc7a64c453208911077c9a4af50e35b32247fc0a35853bb314d0e4289dd07f6116a3ade7fa278b521ed9b7b13db949b
DIST thermald-2.3.tar.gz 452790 BLAKE2B caef87d670b14bfa0dbe6ca4873ebea4b0a9960a9bad48ddb10abb348e25cafdbdf5dad831a1c3ad38e71ab61d7f123df99046dec1e5ce2c32be506bc4b1312f SHA512 0d722c35e3638bb917994b8a123e1226b737b120f0946cfc604eb3bb4bd501121b1f196833f8cb3aceee73a8bb3566ef1d176d81143b84423f89d20966e91ed8
+DIST thermald-2.4.1.tar.gz 455735 BLAKE2B ee4d6bc590bc50639c0b19adbba7e243358174a837b2ff155dea060b1cd09171d4fb77b18b785dc9f64a633f680358cb1d7b36e3bd438e5267e0a0a27e18497e SHA512 2dab7d57e028037208034ab4be95dc138ce028d4a47a0151c69816e1502065d801d52990641544b5d246144e654c15c663fa78af6cea094cf9a107f2fb29c1ef
diff --git a/sys-power/thermald/thermald-2.4.1.ebuild b/sys-power/thermald/thermald-2.4.1.ebuild
new file mode 100644
index 000000000000..64693c99c353
--- /dev/null
+++ b/sys-power/thermald/thermald-2.4.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://01.org/linux-thermal-daemon https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}
+
+pkg_postinst() {
+ if ! has_version sys-power/dptfxtract; then
+ elog "dptfxtract can be used to generate a more specific"
+ elog "thermald configuration for your system"
+ fi
+}