summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-04-17 15:40:24 +0200
committerPacho Ramos <pacho@gentoo.org>2023-04-17 15:40:24 +0200
commita57914d46f229ccceb97642452307ec61fa65473 (patch)
tree0123bcd5238dfde06ea12c4c186b1a51ad6aa6b7 /sys-power
parentsys-power/power-profiles-daemon: Add missing dep (diff)
downloadgentoo-a57914d46f229ccceb97642452307ec61fa65473.tar.gz
gentoo-a57914d46f229ccceb97642452307ec61fa65473.tar.bz2
gentoo-a57914d46f229ccceb97642452307ec61fa65473.zip
sys-power/power-profiles-daemon: drop 0.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/power-profiles-daemon/power-profiles-daemon-0.12.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/sys-power/power-profiles-daemon/power-profiles-daemon-0.12.ebuild b/sys-power/power-profiles-daemon/power-profiles-daemon-0.12.ebuild
deleted file mode 100644
index 6e3f67c1abf2..000000000000
--- a/sys-power/power-profiles-daemon/power-profiles-daemon-0.12.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit meson python-single-r1 systemd
-
-DESCRIPTION="Makes power profiles handling available over D-Bus"
-HOMEPAGE="https://gitlab.freedesktop.org/hadess/power-profiles-daemon/"
-SRC_URI="https://gitlab.freedesktop.org/hadess/${PN}/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="gtk-doc test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
- dev-libs/glib:2
- >=dev-libs/libgudev-234
- >=sys-auth/polkit-0.114
- sys-power/upower
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- gtk-doc? ( dev-util/gi-docgen )
- test? (
- dev-util/umockdev
- $(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-dbusmock[${PYTHON_USEDEP}]
- ')
- )
-"
-
-python_check_deps() {
- if use test; then
- python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&
- python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
- else
- python_has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
- fi
-}
-
-src_configure() {
- local emesonargs=(
- -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
- $(meson_use gtk-doc gtk_doc)
- $(meson_use test tests)
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- python_fix_shebang "${D}"/usr/bin/powerprofilesctl
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- if systemd_is_booted; then
- elog "You need to enable the service:"
- elog "# systemctl enable ${PN}"
- fi
- fi
-}