summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-08-27 11:31:41 +0000
committerYixun Lan <dlan@gentoo.org>2023-08-27 11:33:58 +0000
commita5bdf7b3dc6cbbdc25f74d49ebc55161ce997ae5 (patch)
tree5692229770f120d06b4add33116fddae54502095 /sys-power
parentapp-text/paper-clip: add missing USE requirements (diff)
downloadgentoo-a5bdf7b3dc6cbbdc25f74d49ebc55161ce997ae5.tar.gz
gentoo-a5bdf7b3dc6cbbdc25f74d49ebc55161ce997ae5.tar.bz2
gentoo-a5bdf7b3dc6cbbdc25f74d49ebc55161ce997ae5.zip
sys-power/thermald: add 2.5.4
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.5.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index b6efc663dd7f..2f95b620fb35 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1,2 +1,3 @@
DIST thermald-2.5.2.tar.gz 162307 BLAKE2B 884fbfb440a0b5e9d1d12bfd7b9173fd79f68b46c499e341f0afdf3d312e10bcd5956b14de7c4c8c0b4db1bc7b675025e3b108bc27cc3cbf236212d0bd642508 SHA512 50ec8c0afb62805d4a86eff91725c468c9035d4524d5d12c187c8b5bbff5a6e723ead7a32bda1a2964fa8a8a8ae437bc7c05d657ea1ac64e4a3d32e6dc0591e2
DIST thermald-2.5.3.tar.gz 162876 BLAKE2B bfdd297ff703588433d749bb64d0a0cd803b54192e3ee87449433ba89b726836f4050bbb87b7233fe4519686fdbd9bd23408bbeb6a5c31bfdd8b07aa9b723a47 SHA512 2c46e7e02c6ee375f78c8593765f01ff3be82bda3e90c133a9680bfbe7897a3fff78679e1306ee7d76192d7f164ca0ccbfeafd240c56160cdc9c4167827d5ead
+DIST thermald-2.5.4.tar.gz 179202 BLAKE2B 945466ee90e61b4c59105f6f0d5b011b9cad9a9613ec5ac1f9e8d2ec1d75bc21e1685e7c8f165f5f4f46736d0b862a149b1e1444500d64aa1429d97db85209ac SHA512 7e73e7860ca6df22862db5fad1d8ab75361deac9cb3631da2950b02f366febd78a93c81afe93af396c9be2a809e8be8c764b0d3183b545e051f3ec7b9d9dd078
diff --git a/sys-power/thermald/thermald-2.5.4.ebuild b/sys-power/thermald/thermald-2.5.4.ebuild
new file mode 100644
index 000000000000..2daa0c75f6aa
--- /dev/null
+++ b/sys-power/thermald/thermald-2.5.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib:=
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+S=${WORKDIR}/thermal_daemon-${PV}
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+CONFIG_CHECK="~PERF_EVENTS_INTEL_RAPL ~X86_INTEL_PSTATE ~INTEL_POWERCLAMP ~INT340X_THERMAL ~ACPI_THERMAL_REL ~INT3406_THERMAL"
+
+src_prepare() {
+ sed -i -e '/tdrundir/s@\$localstatedir/run@\$runstatedir@' \
+ configure.ac || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --runstatedir="${EPREFIX}"/run \
+ --with-dbus-power-group=wheel \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}