summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-08-15 17:26:25 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-08-15 17:53:12 +0200
commitbf85f4a8b9f78564f4cdc31b15b06c53137952fe (patch)
tree630624da29f13a2b803acaf7c10466a563c4abc1 /sys-power
parentdev-python/sphinxcontrib-plantuml: new package, add 0.25 (diff)
downloadgentoo-bf85f4a8b9f78564f4cdc31b15b06c53137952fe.tar.gz
gentoo-bf85f4a8b9f78564f4cdc31b15b06c53137952fe.tar.bz2
gentoo-bf85f4a8b9f78564f4cdc31b15b06c53137952fe.zip
sys-power/autosuspend: new package, add 5.0.0
Signed-off-by: Florian Schmaus <flow@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/32259
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/autosuspend/Manifest1
-rw-r--r--sys-power/autosuspend/autosuspend-5.0.0.ebuild70
-rw-r--r--sys-power/autosuspend/metadata.xml14
3 files changed, 85 insertions, 0 deletions
diff --git a/sys-power/autosuspend/Manifest b/sys-power/autosuspend/Manifest
new file mode 100644
index 000000000000..4b00a2015b39
--- /dev/null
+++ b/sys-power/autosuspend/Manifest
@@ -0,0 +1 @@
+DIST autosuspend-5.0.0.gh.tar.gz 179353 BLAKE2B 747f06ea84304acfeca78aa413745c56a63506be039696968e94a43199ee9e4cfa080b187b284a60e16e03bd22674973eaa7ed4728727016a05de12aca94fc9e SHA512 4d1d14e2cc8c7dc7ed1bfa41556ea8afe51785cef3965863fe307469a13f865b76df9a53c531aefef18308a2d57867631d86d59ea189cc56a108f1bdeaf4d369
diff --git a/sys-power/autosuspend/autosuspend-5.0.0.ebuild b/sys-power/autosuspend/autosuspend-5.0.0.ebuild
new file mode 100644
index 000000000000..eb6e1694c159
--- /dev/null
+++ b/sys-power/autosuspend/autosuspend-5.0.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="A daemon to automatically suspend and wake up a system"
+HOMEPAGE="
+ https://github.com/languitar/autosuspend
+ https://autosuspend.readthedocs.io
+"
+SRC_URI="
+ https://github.com/languitar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dbus mpd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/portalocker[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mpd? ( dev-python/python-mpd2[${PYTHON_USEDEP}] )
+"
+
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/jsonpath-ng[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/pytest-datadir[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ dev-python/python-mpd2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ tests/test_checks_util.py::TestNetworkMixin::test_file_url
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source \
+ dev-python/furo \
+ dev-python/recommonmark \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinx-issues \
+ dev-python/sphinxcontrib-plantuml
+
+python_test() {
+ # Disable code coverage in tests by setting addopts to the empty value.
+ epytest -o addopts=
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
diff --git a/sys-power/autosuspend/metadata.xml b/sys-power/autosuspend/metadata.xml
new file mode 100644
index 000000000000..619a131e65bd
--- /dev/null
+++ b/sys-power/autosuspend/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="mpd">Enable support for the Music Player Daemon</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">languitar/autosuspend</remote-id>
+ </upstream>
+</pkgmetadata>