summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-07-29 08:45:15 -0700
committerMatt Turner <mattst88@gentoo.org>2019-07-29 08:48:54 -0700
commitfc6854ed667f0b5298ebb508eca9a0adf6052f39 (patch)
treef6b6a89660474a227ae54a26cb63a52c1a973df3 /sys-power
parentdev-vcs/bzr: arm64 stable (diff)
downloadgentoo-fc6854ed667f0b5298ebb508eca9a0adf6052f39.tar.gz
gentoo-fc6854ed667f0b5298ebb508eca9a0adf6052f39.tar.bz2
gentoo-fc6854ed667f0b5298ebb508eca9a0adf6052f39.zip
sys-power/powertop: Restore mistakenly removed patch
When cleaning up, I deleted the wrong patch and left the unused one in place. Closes: https://bugs.gentoo.org/690992 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/powertop/files/powertop-2.8-ncurses_tinfo.patch41
-rw-r--r--sys-power/powertop/files/powertop-2.9-libc++.patch44
2 files changed, 41 insertions, 44 deletions
diff --git a/sys-power/powertop/files/powertop-2.8-ncurses_tinfo.patch b/sys-power/powertop/files/powertop-2.8-ncurses_tinfo.patch
new file mode 100644
index 000000000000..97769fb6728e
--- /dev/null
+++ b/sys-power/powertop/files/powertop-2.8-ncurses_tinfo.patch
@@ -0,0 +1,41 @@
+From e1295099f8b42670718ba875cb6749a90042293f Mon Sep 17 00:00:00 2001
+From: Zentaro Kavanagh <zentaro@chromium.org>
+Date: Thu, 14 Jun 2018 13:13:37 -0700
+Subject: [PATCH] Fix configure to support ncurses w/ tinfo
+
+- The existing code checked for both ncursesw and ncurses and if
+ both were not found, NCURSES_LIBS was not set correctly.
+- Removed redundant concatenation to $LIBS since the makefile.am
+ already maps NCURSES_LIBS into LIBS.
+- Patch sent upstream to powertop mailing list [1]
+
+[1] - https://lists.01.org/pipermail/powertop/2018-June/002021.html
+---
+ configure.ac | 11 +++++++----
+ 1 file changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d6a15e1..c6ee50a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -110,10 +110,13 @@ AC_CHECK_FUNCS([ \
+
+ AC_SEARCH_LIBS([clock_gettime], [rt])
+
+-PKG_CHECK_MODULES([NCURSES], [ncursesw ncurses], [LIBS="$LIBS $ncurses_LIBS"], [
+- AC_SEARCH_LIBS([delwin], [ncursesw ncurses], [], [
+- AC_MSG_ERROR([ncurses is required but was not found])
+- ], [])
++PKG_CHECK_MODULES([ncursesw], [ncursesw],
++ [NCURSES_CFLAGS="$ncursesw_CFLAGS"; NCURSES_LIBS="$ncursesw_LIBS"], [
++ PKG_CHECK_MODULES([NCURSES], [ncurses], [], [
++ AC_SEARCH_LIBS([delwin], [ncursesw ncurses], [], [
++ AC_MSG_ERROR([ncurses is required but was not found])
++ ])
++ ])
+ ])
+
+ has_libpci=0
+--
+2.18.0.rc1.242.g61856ae69a-goog
+
diff --git a/sys-power/powertop/files/powertop-2.9-libc++.patch b/sys-power/powertop/files/powertop-2.9-libc++.patch
deleted file mode 100644
index d378280f3c68..000000000000
--- a/sys-power/powertop/files/powertop-2.9-libc++.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-https://github.com/fenrus75/powertop/commit/b9c431aad6cc5383c9571007469eee8e64ec85a6
-
-From b9c431aad6cc5383c9571007469eee8e64ec85a6 Mon Sep 17 00:00:00 2001
-From: Manoj Gupta <manojgupta@chromium.org>
-Date: Sat, 4 Nov 2017 13:44:04 -0700
-Subject: [PATCH] Fix powertop build with libc++.
-
-<ctime> header is not automatically included with libc++.
-Add it explicitly to make powertop build with libc++.
-
-This fixes the following errors:
-devices/gpu_rapl_device.cpp:35:14: error: use of undeclared identifier
-'time'; did you mean 'tie'?
-last_time = time(NULL);
- ^~~~
-devices/gpu_rapl_device.cpp:45:14: error:use of undeclared identifier
-'time'; did you mean 'tie'?
-last_time = time(NULL);
- ^~~~
-
-parameters/learn.cpp:161:10: error: use of undeclared identifier
-'time'; did you mean 'tie'?
-start = time(NULL);
- ^~~~
----
- src/lib.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/lib.h b/src/lib.h
-index b64bb0f5433f..6d85eb6e4b40 100644
---- a/src/lib.h
-+++ b/src/lib.h
-@@ -54,7 +54,7 @@ extern const char *kernel_function(uint64_t address);
-
-
-
--
-+#include <ctime>
- #include <string>
- using namespace std;
-
---
-2.15.1
-