summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-15 16:32:18 +0100
committerSam James <sam@gentoo.org>2022-10-15 16:32:18 +0100
commit4ad32b26a7dbe6246d756d185a694f679997ac1c (patch)
tree9c9bc61fc4acf778007eb2529980f2914403b831 /sys-process/at
parentdev-libs/rocm-comgr: fix MissingSlotDep on LLD (diff)
downloadgentoo-4ad32b26a7dbe6246d756d185a694f679997ac1c.tar.gz
gentoo-4ad32b26a7dbe6246d756d185a694f679997ac1c.tar.bz2
gentoo-4ad32b26a7dbe6246d756d185a694f679997ac1c.zip
sys-process/at: drop 3.2.2-r2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/at')
-rw-r--r--sys-process/at/Manifest1
-rw-r--r--sys-process/at/at-3.2.2-r2.ebuild97
2 files changed, 0 insertions, 98 deletions
diff --git a/sys-process/at/Manifest b/sys-process/at/Manifest
index 11ae77710258..880acbd66623 100644
--- a/sys-process/at/Manifest
+++ b/sys-process/at/Manifest
@@ -1,2 +1 @@
-DIST at_3.2.2.orig.tar.gz 127677 BLAKE2B f4b0e1cd09d1e679d0bcc287462300827d12663927dce1534a74bd4ecd670f903a81cd6147c03b0e55192655c2a99250c27ad0e9892342d91b0279210fb79a64 SHA512 e6f5aeddd89438aadff627d654ebc821a0b0e1a600ebaacc8a5fd3ec2c7c716f593757d00501311736d28f6d4276899667d6901d70836af208ff7d181b5b680f
DIST at_3.2.5.orig.tar.gz 132660 BLAKE2B 30cd8e53aff8176ceea62f2a34c0cc0706b35fc187c2da58f86ec6ca4cec4701bfab9d932949d57b9750a18841d315d7c9a4289691f209c899598991f6541a32 SHA512 542e8948bbdc1d06934070cbfe242688b541ef6342c6b0351255f8b9d7a3ed915a9304b5cf5442dfc15845b3d2b926ebecbfc5bccd204519d0a2775b27f8139c
diff --git a/sys-process/at/at-3.2.2-r2.ebuild b/sys-process/at/at-3.2.2-r2.ebuild
deleted file mode 100644
index 3f39f76a02ae..000000000000
--- a/sys-process/at/at-3.2.2-r2.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools pam systemd
-
-MY_P="${PN}_${PV}"
-
-DESCRIPTION="Queues jobs for later execution"
-HOMEPAGE="http://blog.calhariz.com/index.php/tag/at https://packages.qa.debian.org/a/at.html"
-SRC_URI="http://software.calhariz.com/at/${MY_P}.orig.tar.gz
- mirror://debian/pool/main/a/at/${MY_P}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="pam selinux"
-
-DEPEND="
- acct-group/at
- acct-user/at
- virtual/mta
- pam? ( sys-libs/pam )
-"
-RDEPEND="${DEPEND}
- virtual/mta
- virtual/logger
- selinux? ( sec-policy/selinux-at )
-"
-BDEPEND="
- >=sys-devel/autoconf-2.64
- sys-devel/bison
- >=sys-devel/flex-2.5.4a
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
- "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
- # fix parallel make issues, bug #244884
- "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
- "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
- # Fix parallel make issue (bug #408375)
- "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
- "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --sysconfdir="${EPREFIX}"/etc/at
- --with-jobdir="${EPREFIX}"/var/spool/at/atjobs
- --with-atspool="${EPREFIX}"/var/spool/at/atspool
- --with-etcdir="${EPREFIX}"/etc/at
- --with-daemon_username=at
- --with-daemon_groupname=at
- $(usex pam '' --without-pam)
- $(use_with selinux)
- )
- econf ${myeconfargs[@]}
-}
-
-src_install() {
- emake install IROOT="${D}"
-
- newinitd "${FILESDIR}"/atd.rc8 atd
- newconfd "${FILESDIR}"/atd.confd atd
-
- if use pam ; then
- newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
- fi
-
- # Preserve existing .SEQ files (bug #386625)
- local seq_file="${EROOT}/var/spool/at/atjobs/.SEQ"
- if [[ -f "${seq_file}" ]] ; then
- einfo "Preserving existing .SEQ file (bug #386625)."
- cp -p "${seq_file}" "${ED}"/var/spool/at/atjobs/ || die
- fi
-
- systemd_dounit "${FILESDIR}/atd.service"
- keepdir /var/spool/at/atspool
-}
-
-pkg_postinst() {
- einfo "Forcing correct permissions on /var/spool/at"
- local atspooldir="${EROOT}/var/spool/at"
- chown at:at "${atspooldir}/atjobs"
- chmod 1770 "${atspooldir}/atjobs"
- chown at:at "${atspooldir}/atjobs/.SEQ"
- chmod 0600 "${atspooldir}/atjobs/.SEQ"
- chown at:at "${atspooldir}/atspool"
- chmod 1770 "${atspooldir}/atspool"
-}