summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-01-29 11:49:20 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-01-29 11:49:20 -0800
commit2418aff6c39849c986cba64e4bd5a1e8cab4cb9d (patch)
tree1ab822738ade11d6cd16f81489307269433438e3 /sys-process/bpytop
parentapp-misc/tmuxp: Version bump to 1.9.4 (diff)
downloadgentoo-2418aff6c39849c986cba64e4bd5a1e8cab4cb9d.tar.gz
gentoo-2418aff6c39849c986cba64e4bd5a1e8cab4cb9d.tar.bz2
gentoo-2418aff6c39849c986cba64e4bd5a1e8cab4cb9d.zip
sys-process/bpytop: Version bump to 1.0.68
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-process/bpytop')
-rw-r--r--sys-process/bpytop/Manifest1
-rw-r--r--sys-process/bpytop/bpytop-1.0.68.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-process/bpytop/Manifest b/sys-process/bpytop/Manifest
index 5f7978c3acfb..4bc16f0e6212 100644
--- a/sys-process/bpytop/Manifest
+++ b/sys-process/bpytop/Manifest
@@ -1,3 +1,4 @@
DIST bpytop-1.0.61.tar.gz 626468 BLAKE2B 84a9bbaec6af27b06af53acbe2e735421de3bc4567fcf7fb29d05f801f7414b4e035e67a2fecb27a45d4d91c1d6ef527a16775f44c2e5620ecf797794969a2d2 SHA512 639e0d94bd500477b8288400c6fa1769f1b7327733bec8292e72eb3024e26f6242901970dfc539d9fb309f69299ea934e02ab93226f907ddbbefb670bffb027c
DIST bpytop-1.0.63.tar.gz 627729 BLAKE2B a61d7c101c05d8e706b5c89f3c52dd02cf99e126d73f4cdb58adf8e474774e618abce7184a6fcf1c1b69f4c491b088c4c715d7b803c56933e1a8eeb8efa77fec SHA512 85334a43137466992fe3003f7f29b6a66b41732d1953fd5653ce277d35735127eef97607599906c0d0cfc7323852da75541b2ae79db22f843892097a2d3398e4
DIST bpytop-1.0.67.tar.gz 628491 BLAKE2B 9ce35332dde806d132fee42f04f787e9220f05644e938d83725369157032a556c89d216a393a52a26fa6c6841a2b91b8212ee122ba734e1aedc912f7a02d350b SHA512 bfd6b365d4d76521cb5d1edccfd858732143a1a9273dc0e17d348c824c125df904b1160d9e7f81d718f880c4f3eea33d045a684706039bceb7f95ed67df2b56b
+DIST bpytop-1.0.68.tar.gz 632649 BLAKE2B a32a3b583b31c2c2013f4d2bb8834cf02a8702d37f723e304691eecdebcf32e21f639428abe7f5251c075aa73ed46f610e47c4241092455351001c31b2a051b5 SHA512 88a8be5cb5bbf5516dbafeb4d513d6a489ae9a8a84de316e2331a428cd4f338f8e01ed2eedd92c610b722c06dd968d85baf27692316f905855aca3d8a67a731d
diff --git a/sys-process/bpytop/bpytop-1.0.68.ebuild b/sys-process/bpytop/bpytop-1.0.68.ebuild
new file mode 100644
index 000000000000..9cd9d1c11448
--- /dev/null
+++ b/sys-process/bpytop/bpytop-1.0.68.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
+HOMEPAGE="https://github.com/aristocratos/bpytop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/bpytop-1.0.63-tests.patch"
+)
+
+src_install() {
+ insinto "/usr/share/${PN}/themes"
+ doins bpytop-themes/*.theme
+ distutils-r1_src_install
+}