summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-09-20 09:44:51 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-09-20 09:46:21 -0700
commite1dfa50ec3b3dfa5d4c3788ab25f545e9b169e24 (patch)
tree43a64d8fbf28616069fde2ab42eeee81829ea0e1 /sys-process/bpytop
parentdev-lang/python: Remove old (diff)
downloadgentoo-e1dfa50ec3b3dfa5d4c3788ab25f545e9b169e24.tar.gz
gentoo-e1dfa50ec3b3dfa5d4c3788ab25f545e9b169e24.tar.bz2
gentoo-e1dfa50ec3b3dfa5d4c3788ab25f545e9b169e24.zip
sys-process/bpytop-1.0.67: Version bump
Closes: https://bugs.gentoo.org/795468 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-process/bpytop')
-rw-r--r--sys-process/bpytop/Manifest1
-rw-r--r--sys-process/bpytop/bpytop-1.0.67.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-process/bpytop/Manifest b/sys-process/bpytop/Manifest
index a3bb080533fc..5f7978c3acfb 100644
--- a/sys-process/bpytop/Manifest
+++ b/sys-process/bpytop/Manifest
@@ -1,2 +1,3 @@
DIST bpytop-1.0.61.tar.gz 626468 BLAKE2B 84a9bbaec6af27b06af53acbe2e735421de3bc4567fcf7fb29d05f801f7414b4e035e67a2fecb27a45d4d91c1d6ef527a16775f44c2e5620ecf797794969a2d2 SHA512 639e0d94bd500477b8288400c6fa1769f1b7327733bec8292e72eb3024e26f6242901970dfc539d9fb309f69299ea934e02ab93226f907ddbbefb670bffb027c
DIST bpytop-1.0.63.tar.gz 627729 BLAKE2B a61d7c101c05d8e706b5c89f3c52dd02cf99e126d73f4cdb58adf8e474774e618abce7184a6fcf1c1b69f4c491b088c4c715d7b803c56933e1a8eeb8efa77fec SHA512 85334a43137466992fe3003f7f29b6a66b41732d1953fd5653ce277d35735127eef97607599906c0d0cfc7323852da75541b2ae79db22f843892097a2d3398e4
+DIST bpytop-1.0.67.tar.gz 628491 BLAKE2B 9ce35332dde806d132fee42f04f787e9220f05644e938d83725369157032a556c89d216a393a52a26fa6c6841a2b91b8212ee122ba734e1aedc912f7a02d350b SHA512 bfd6b365d4d76521cb5d1edccfd858732143a1a9273dc0e17d348c824c125df904b1160d9e7f81d718f880c4f3eea33d045a684706039bceb7f95ed67df2b56b
diff --git a/sys-process/bpytop/bpytop-1.0.67.ebuild b/sys-process/bpytop/bpytop-1.0.67.ebuild
new file mode 100644
index 000000000000..635e16b769aa
--- /dev/null
+++ b/sys-process/bpytop/bpytop-1.0.67.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
+HOMEPAGE="https://github.com/aristocratos/bpytop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/bpytop-1.0.63-tests.patch"
+)
+
+src_install() {
+ insinto "/usr/share/${PN}/themes"
+ doins bpytop-themes/*.theme
+ distutils-r1_src_install
+}