summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-11-12 20:56:16 +0000
committerJustin Lecher <jlec@gentoo.org>2017-11-12 21:08:50 +0000
commit650df73029f572640645c696911385a9ec57982a (patch)
tree8e22fec7d3e158ad05531e4eec1b3514cb60624c /sys-process/criu
parentsys-auth/munge: Version Bump (diff)
downloadgentoo-650df73029f572640645c696911385a9ec57982a.tar.gz
gentoo-650df73029f572640645c696911385a9ec57982a.tar.bz2
gentoo-650df73029f572640645c696911385a9ec57982a.zip
sys-process/criu: Version Bump
handle automagic dep in selinux Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'sys-process/criu')
-rw-r--r--sys-process/criu/Manifest1
-rw-r--r--sys-process/criu/criu-3.6.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/sys-process/criu/Manifest b/sys-process/criu/Manifest
index 3a5845f0c3ca..84358d544f74 100644
--- a/sys-process/criu/Manifest
+++ b/sys-process/criu/Manifest
@@ -5,3 +5,4 @@ DIST criu-2.12.1.tar.bz2 646855 SHA256 33e4f575a533b66e0571fff0c2b6ced51612789fa
DIST criu-2.12.tar.bz2 646770 SHA256 b707eee3410a833b2d5d7534557c7a21f800f10d8660966d1efdd6396f1a1e4b SHA512 e021772c5d42dd93fe0d6c10a7aa731b600871ba78772169323c661c59d00f4d78ceda3ddfbda76123947f6ff6d2c19e443bb73e018a649e7f3872b73d28763a WHIRLPOOL 19017b586cf5a490393c8b3b3d9ca98f6aa5442812cf4eb8bca45efa7f04c2360d7cbd46c40f1abf84ee6ba82ff2ecc6256f54d553259783a2ba4c36aa7dbaad
DIST criu-2.5.tar.bz2 605226 SHA256 d2a9ffec0b659c3d3a71e1d473e95e36b208b2563f136ce8f471ff9600fcc51a SHA512 ccf942005ff3b2a567726ddb8aa44048c130f1adf6e2cbdf48e919043c84a4e1c03ad0ec34b44263e5764bea62807a2cc0fa1135b929ad3166fb9486c2880570 WHIRLPOOL 9896fe45d4516a73e6b7c403a044d25902ed4a9000b0a0a053ff9d52c053adfb58c8ce0225b9841bc7e2f38de6a8e4fc6d3073d878ea5b09b81cc89cba91de62
DIST criu-3.4.tar.bz2 701680 SHA256 876bf32b9351c0034ff8f7064a6e63487f6639aedec115356cc76c436fa437c2 SHA512 71fc700d19b46381873b2d0fa90e7fa253b00beb5e4e6065bbf510766acbcc14b35d58fa8073801112f897d2320b7decca1115fb6853d5fe64f3c52aa40a9f32 WHIRLPOOL 39be8e58635f21868f152a50f163875812d1325212b0c0c5a360152869e03358eb449b86700ee6f242cb890fcf5217c2aceaf3b2781e3b2d7c70ecc1a6c933df
+DIST criu-3.6.tar.bz2 739437 SHA256 de1d612fdf020c34f5cb2932c88e9e330ae1e4c6547b31b81d6d9b2da7bb2ca3 SHA512 5849024ac4660a5537ed37b6d98adf61d3f071e2a181d873a1f7ca6c4d00a4258445b4bc840e908d907bc34daf8a818450f54e6cdf4826a679e756c0cbc5d586 WHIRLPOOL 89f93cd908a597276e88a9e337353d7f088abb60331737cafcf2b2f1450b025e8452690530c731cae86dcada500d7cde1d846d792a589d4c8806ecb15d76b762
diff --git a/sys-process/criu/criu-3.6.ebuild b/sys-process/criu/criu-3.6.ebuild
new file mode 100644
index 000000000000..b0ed466c0a8c
--- /dev/null
+++ b/sys-process/criu/criu-3.6.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils toolchain-funcs linux-info flag-o-matic python-r1 python-utils-r1
+
+DESCRIPTION="utility to checkpoint/restore a process tree"
+HOMEPAGE="http://criu.org/"
+SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="python selinux setproctitle static-libs"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/protobuf-c
+ dev-libs/libnl:3
+ net-libs/libnet:1.1
+ sys-libs/libcap
+ python? ( ${PYTHON_DEPS} )
+ selinux? ( sys-libs/libselinux )
+ setproctitle? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto"
+RDEPEND="${RDEPEND}
+ python? (
+ || (
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-libs/protobuf[python,${PYTHON_USEDEP}]
+ )
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ )"
+
+CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
+ ~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/2.2/${PN}-2.2-flags.patch
+ "${FILESDIR}"/2.3/${PN}-2.3-no-git.patch
+ "${FILESDIR}"/${PN}-2.8-automagic-libbsd.patch
+ "${FILESDIR}"/2.0/${PN}-2.0-sysroot.patch
+)
+
+criu_arch() {
+ # criu infers the arch from $(uname -m). We never want this to happen.
+ case ${ARCH} in
+ amd64) echo "x86";;
+ arm64) echo "aarch64";;
+ *) echo "${ARCH}";;
+ esac
+}
+
+src_prepare() {
+ default
+
+ if ! use selinux; then
+ sed \
+ -e 's:libselinux:no_libselinux:g' \
+ -i Makefile.config || die
+ fi
+}
+
+src_compile() {
+ RAW_LDFLAGS="$(raw-ldflags)" emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ ARCH="$(criu_arch)" \
+ V=1 WERROR=0 DEBUG=0 \
+ SETPROCTITLE=$(usex setproctitle) \
+ PYCRIU=$(usex python) \
+ all docs
+}
+
+src_test() {
+ # root privileges are required to dump all necessary info
+ if [[ ${EUID} -eq 0 ]] ; then
+ emake -j1 CC="$(tc-getCC)" ARCH="$(criu_arch)" V=1 WERROR=0 test
+ fi
+}
+
+install_crit() {
+ "${PYTHON:-python}" ../scripts/crit-setup.py install --root="${D}" --prefix="${EPREFIX}/usr/"
+}
+
+src_install() {
+ emake \
+ ARCH="$(criu_arch)" \
+ PREFIX="${EPREFIX}"/usr \
+ LOGROTATEDIR="${EPREFIX}"/etc/logrotate.d \
+ DESTDIR="${D}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install
+
+ dodoc CREDITS README.md
+
+ if use python ; then
+ cd lib
+ python_foreach_impl install_crit
+ fi
+
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -delete || die
+ fi
+}