summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-23 13:10:12 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-23 13:10:30 +0100
commit6ba0a475569468dcf6d36805833207eb75854189 (patch)
tree7c16134d1958ba48529fdd41a65fa87401b986f0 /sys-process/cronie/cronie-1.5.1.ebuild
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-6ba0a475569468dcf6d36805833207eb75854189.tar.gz
gentoo-6ba0a475569468dcf6d36805833207eb75854189.tar.bz2
gentoo-6ba0a475569468dcf6d36805833207eb75854189.zip
sys-process/cronie: Changed HOMEPAGE from fedorahosted to github.
This also resulted in a different source tarball for version 1.5.1 because the tarball on github does not contain any pre-processed autotools files. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-process/cronie/cronie-1.5.1.ebuild')
-rw-r--r--sys-process/cronie/cronie-1.5.1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/sys-process/cronie/cronie-1.5.1.ebuild b/sys-process/cronie/cronie-1.5.1.ebuild
index a70590a8a089..baf6397d15e7 100644
--- a/sys-process/cronie/cronie-1.5.1.ebuild
+++ b/sys-process/cronie/cronie-1.5.1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit cron eutils pam systemd user
+inherit autotools cron eutils pam systemd user
DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
-SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
-HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+HOMEPAGE="https://github.com/cronie-crond/cronie"
+SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
LICENSE="ISC BSD BSD-2 GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -21,14 +21,21 @@ RDEPEND="${DEPEND}"
#cronie supports /etc/crontab
CRON_SYSTEM_CRONTAB="yes"
-pkg_setup() {
- enewgroup crontab
-}
+S="${WORKDIR}/${PN}-${P}"
PATCHES=(
"${FILESDIR}/cronie-systemd.patch"
)
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
SPOOL_DIR="/var/spool/cron/crontabs" \
ANACRON_SPOOL_DIR="/var/spool/anacron" \