summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-07 15:47:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-07 18:05:14 +0100
commit4dd796748cf5b8455513b658d813a1765e987a68 (patch)
tree850787b3f105f30fc18702568714ccf4ab8d93de /sys-process/daemontools/daemontools-0.76-r8.ebuild
parentsys-fs/lufs: EAPI-7 revbump (diff)
downloadgentoo-4dd796748cf5b8455513b658d813a1765e987a68.tar.gz
gentoo-4dd796748cf5b8455513b658d813a1765e987a68.tar.bz2
gentoo-4dd796748cf5b8455513b658d813a1765e987a68.zip
sys-process/daemontools: EAPI-7 revbump
Closes: https://bugs.gentoo.org/697166 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process/daemontools/daemontools-0.76-r8.ebuild')
-rw-r--r--sys-process/daemontools/daemontools-0.76-r8.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-process/daemontools/daemontools-0.76-r8.ebuild b/sys-process/daemontools/daemontools-0.76-r8.ebuild
new file mode 100644
index 000000000000..98a029774410
--- /dev/null
+++ b/sys-process/daemontools/daemontools-0.76-r8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://cr.yp.to/daemontools.html"
+SRC_URI="http://cr.yp.to/daemontools/${P}.tar.gz
+ http://smarden.org/pape/djb/manpages/${P}-man-20020131.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+ !app-doc/daemontools-man"
+
+S="${WORKDIR}/admin/${P}/src"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-errno.patch
+ "${FILESDIR}"/${PV}-warnings.patch
+)
+
+src_prepare() {
+ default
+
+ ht_fix_file Makefile print-{cc,ld}.sh
+
+ use static && append-ldflags -static
+ qmail_set_cc
+}
+
+src_compile() {
+ touch home || die
+ emake
+}
+
+src_install() {
+ keepdir /service
+
+ dobin $(<../package/commands)
+ dodoc CHANGES ../package/README TODO
+ doman "${WORKDIR}"/${PN}-man/*.8
+
+ newinitd "${FILESDIR}"/svscan.init-0.76-r7 svscan
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}