summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/daemontools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/daemontools')
-rw-r--r--sys-process/daemontools/Manifest2
-rw-r--r--sys-process/daemontools/daemontools-0.76-r7.ebuild58
-rw-r--r--sys-process/daemontools/files/0.76-errno.patch11
-rw-r--r--sys-process/daemontools/files/0.76-warnings.patch74
-rw-r--r--sys-process/daemontools/files/svscan.init32
-rw-r--r--sys-process/daemontools/files/svscan.init-0.76-r732
-rw-r--r--sys-process/daemontools/metadata.xml5
7 files changed, 214 insertions, 0 deletions
diff --git a/sys-process/daemontools/Manifest b/sys-process/daemontools/Manifest
new file mode 100644
index 000000000000..a6a335ba6519
--- /dev/null
+++ b/sys-process/daemontools/Manifest
@@ -0,0 +1,2 @@
+DIST daemontools-0.76-man-20020131.tar.gz 8005 RMD160 d82f0bad55f0751fdfadfa0f3bf2883740fa65d9 SHA1 28e167def0e457f2be10aa90504c402fa08723ab SHA256 1b4d77afe0878a0df587672531a3f7bbe0feb7ad0e9acf50395426e3c434600a
+DIST daemontools-0.76.tar.gz 36975 RMD160 9819dae18b3f15a366e49fea81ecef76d5b4f53f SHA1 70a1be67e7dbe0192a887905846acc99ad5ce5b7 SHA256 a55535012b2be7a52dcd9eccabb9a198b13be50d0384143bd3b32b8710df4c1f
diff --git a/sys-process/daemontools/daemontools-0.76-r7.ebuild b/sys-process/daemontools/daemontools-0.76-r7.ebuild
new file mode 100644
index 000000000000..0f405e43e844
--- /dev/null
+++ b/sys-process/daemontools/daemontools-0.76-r7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://cr.yp.to/daemontools.html"
+SRC_URI="http://cr.yp.to/daemontools/${P}.tar.gz
+ http://smarden.org/pape/djb/manpages/${P}-man-20020131.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+ !app-doc/daemontools-man"
+
+S="${WORKDIR}"/admin/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-warnings.patch
+ ht_fix_file Makefile print-{cc,ld}.sh
+
+ use static && append-ldflags -static
+ qmail_set_cc
+}
+
+src_compile() {
+ touch home
+ emake || die
+}
+
+src_install() {
+ keepdir /service
+
+ dobin $(<../package/commands) || die
+ dodoc CHANGES ../package/README TODO
+ doman "${WORKDIR}"/${PN}-man/*.8
+
+ newinitd "${FILESDIR}"/svscan.init-0.76-r7 svscan
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}
diff --git a/sys-process/daemontools/files/0.76-errno.patch b/sys-process/daemontools/files/0.76-errno.patch
new file mode 100644
index 000000000000..3af157c462c9
--- /dev/null
+++ b/sys-process/daemontools/files/0.76-errno.patch
@@ -0,0 +1,11 @@
+--- src/error.h 2001-07-12 11:49:49.000000000 -0500
++++ src/error.h 2003-02-26 02:14:06.000000000 -0600
+@@ -3,7 +3,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/sys-process/daemontools/files/0.76-warnings.patch b/sys-process/daemontools/files/0.76-warnings.patch
new file mode 100644
index 000000000000..f558bb18b1bf
--- /dev/null
+++ b/sys-process/daemontools/files/0.76-warnings.patch
@@ -0,0 +1,74 @@
+Fixup misc warnings
+
+Patch by RiverRat
+
+http://bugs.gentoo.org/124487
+
+--- src/chkshsgr.c
++++ src/chkshsgr.c
+@@ -1,10 +1,13 @@
+ /* Public domain. */
+
++#include <sys/types.h>
++#include <stdlib.h>
++#include <grp.h>
+ #include <unistd.h>
+
+ int main()
+ {
+- short x[4];
++ gid_t x[4];
+
+ x[0] = x[1] = 0;
+ if (getgroups(1,x) == 0) if (setgroups(1,x) == -1) _exit(1);
+--- src/matchtest.c
++++ src/matchtest.c
+@@ -1,3 +1,4 @@
++#include <unistd.h>
+ #include "match.h"
+ #include "buffer.h"
+ #include "str.h"
+--- src/multilog.c
++++ src/multilog.c
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- src/prot.c
++++ src/prot.c
+@@ -1,5 +1,8 @@
+ /* Public domain. */
+
++#include <sys/types.h>
++#include <unistd.h>
++#include <grp.h>
+ #include "hasshsgr.h"
+ #include "prot.h"
+
+--- src/seek_set.c
++++ src/seek_set.c
+@@ -1,6 +1,7 @@
+ /* Public domain. */
+
+ #include <sys/types.h>
++#include <unistd.h>
+ #include "seek.h"
+
+ #define SET 0 /* sigh */
+--- src/supervise.c
++++ src/supervise.c
+@@ -1,3 +1,4 @@
++#include <stdio.h>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- src/pathexec_run.c
++++ src/pathexec_run.c
+@@ -1,5 +1,6 @@
+ /* Public domain. */
+
++#include <unistd.h>
+ #include "error.h"
+ #include "stralloc.h"
+ #include "str.h"
diff --git a/sys-process/daemontools/files/svscan.init b/sys-process/daemontools/files/svscan.init
new file mode 100644
index 000000000000..18c642d5d731
--- /dev/null
+++ b/sys-process/daemontools/files/svscan.init
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net
+ before ntpd ntp-client spamd apache apache2
+}
+
+start() {
+ ebegin "Starting service scan"
+ start-stop-daemon --start --exec /usr/bin/svscan \
+ --background --make-pidfile \
+ --pidfile /var/run/svscan.pid -- /service
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping service scan"
+ start-stop-daemon --stop --exec /usr/bin/svscan \
+ --pidfile /var/run/svscan.pid
+ eend $?
+
+ ebegin "Stopping service scan services"
+ svc -dx /service/* 2>/dev/null
+ eend $?
+
+ ebegin "Stopping service scan logging"
+ svc -dx /service/*/log 2>/dev/null
+ eend $?
+}
diff --git a/sys-process/daemontools/files/svscan.init-0.76-r7 b/sys-process/daemontools/files/svscan.init-0.76-r7
new file mode 100644
index 000000000000..5b157b75eabf
--- /dev/null
+++ b/sys-process/daemontools/files/svscan.init-0.76-r7
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net
+ before ntpd ntp-client spamd apache apache2
+}
+
+start() {
+ ebegin "Starting service scan"
+ setsid start-stop-daemon --start --exec /usr/bin/svscan \
+ --background --make-pidfile \
+ --pidfile /var/run/svscan.pid -- /service
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping service scan"
+ start-stop-daemon --stop --exec /usr/bin/svscan \
+ --pidfile /var/run/svscan.pid
+ eend $?
+
+ ebegin "Stopping service scan services"
+ svc -dx /service/* 2>/dev/null
+ eend $?
+
+ ebegin "Stopping service scan logging"
+ svc -dx /service/*/log 2>/dev/null
+ eend $?
+}
diff --git a/sys-process/daemontools/metadata.xml b/sys-process/daemontools/metadata.xml
new file mode 100644
index 000000000000..659da0ca93c2
--- /dev/null
+++ b/sys-process/daemontools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+</pkgmetadata>