summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-01-29 16:45:43 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-01-29 16:45:43 +0100
commitc3cd21d7eec750f00a8204eef7e7b3ca0debed73 (patch)
treed7526781a2ef94fc9d112d4e773081e66c6ef14d /sys-process/dumb-init/dumb-init-1.2.1.ebuild
parentapp-admin/su-exec: Add support for static build (diff)
downloadgentoo-c3cd21d7eec750f00a8204eef7e7b3ca0debed73.tar.gz
gentoo-c3cd21d7eec750f00a8204eef7e7b3ca0debed73.tar.bz2
gentoo-c3cd21d7eec750f00a8204eef7e7b3ca0debed73.zip
sys-process/dumb-init: Version bump to 1.2.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-process/dumb-init/dumb-init-1.2.1.ebuild')
-rw-r--r--sys-process/dumb-init/dumb-init-1.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-process/dumb-init/dumb-init-1.2.1.ebuild b/sys-process/dumb-init/dumb-init-1.2.1.ebuild
new file mode 100644
index 000000000000..010813709c27
--- /dev/null
+++ b/sys-process/dumb-init/dumb-init-1.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A minimal init system for Linux containers"
+HOMEPAGE="https://github.com/Yelp/dumb-init"
+SRC_URI="https://github.com/Yelp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ use static && append-cflags -static
+ sed -e "s|^CFLAGS=.*|CFLAGS=-std=gnu99 ${CFLAGS}|" -i Makefile || die
+}
+
+src_compile() {
+ CC=$(tc-getCC) emake
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+}