summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-10-15 15:19:01 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-15 15:19:28 +0200
commit43bcbfc4f348226da9d685fbe5c5169fbd007302 (patch)
tree8d26dc55863aae7e19d239ca8b0267f430c1ebbf /sys-process/memwatch/memwatch-0.3.3.ebuild
parentx11-misc/bumblebee: accept user patches (diff)
downloadgentoo-43bcbfc4f348226da9d685fbe5c5169fbd007302.tar.gz
gentoo-43bcbfc4f348226da9d685fbe5c5169fbd007302.tar.bz2
gentoo-43bcbfc4f348226da9d685fbe5c5169fbd007302.zip
sys-process/memwatch: version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-process/memwatch/memwatch-0.3.3.ebuild')
-rw-r--r--sys-process/memwatch/memwatch-0.3.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/memwatch/memwatch-0.3.3.ebuild b/sys-process/memwatch/memwatch-0.3.3.ebuild
new file mode 100644
index 000000000000..804b28eaef3d
--- /dev/null
+++ b/sys-process/memwatch/memwatch-0.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Interactive memory viewer"
+HOMEPAGE="https://unixdev.ru/memwatch"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+CMAKE_REMOVE_MODULES_LIST="FindCurses"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}