summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2022-02-26 21:48:46 +0100
committerPatrice Clement <monsieurp@gentoo.org>2022-02-26 22:03:03 +0100
commit5b4114b402fb02e7ac9d54d0af0d11ea6bf416ef (patch)
treeb4ea538760a444794ad73025d81b8afc3ae9ebdd /sys-process/memwatch
parentnet-im/biboumi: add 9.0-r3 with fix for newer libexpat (diff)
downloadgentoo-5b4114b402fb02e7ac9d54d0af0d11ea6bf416ef.tar.gz
gentoo-5b4114b402fb02e7ac9d54d0af0d11ea6bf416ef.tar.bz2
gentoo-5b4114b402fb02e7ac9d54d0af0d11ea6bf416ef.zip
sys-process/memwatch: update EAPI 6 -> 8
Migrate from cmake-utils to cmake. Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-process/memwatch')
-rw-r--r--sys-process/memwatch/memwatch-0.3.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-process/memwatch/memwatch-0.3.3-r1.ebuild b/sys-process/memwatch/memwatch-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..3d95dc363e12
--- /dev/null
+++ b/sys-process/memwatch/memwatch-0.3.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_REMOVE_MODULES_LIST=( FindCurses )
+inherit cmake
+
+DESCRIPTION="Interactive memory viewer"
+HOMEPAGE="https://unixdev.ru/memwatch"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e "s/^set(CMAKE_C_FLAGS.*/set(CMAKE_C_FLAGS \"${CFLAGS}\")/" \
+ -e "1s/^/project(${PN})\n/" \
+ -i CMakeLists.txt || die "can't patch CMakeLists.txt"
+
+ cmake_src_prepare
+}