summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/minit/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/minit/files')
-rw-r--r--sys-process/minit/files/0.9.1-destdir.patch16
-rw-r--r--sys-process/minit/files/minit-0.10-fixes.diff62
2 files changed, 78 insertions, 0 deletions
diff --git a/sys-process/minit/files/0.9.1-destdir.patch b/sys-process/minit/files/0.9.1-destdir.patch
new file mode 100644
index 000000000000..7a36d3cdfde7
--- /dev/null
+++ b/sys-process/minit/files/0.9.1-destdir.patch
@@ -0,0 +1,16 @@
+--- Makefile.orig 2004-03-04 03:08:18.967017104 -0500
++++ Makefile 2004-03-04 03:10:11.445917712 -0500
+@@ -36,10 +36,12 @@
+ $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+
+ install-files:
++ test -d $(DESTDIR)/sbin || mkdir -p $(DESTDIR)/sbin
+ install minit pidfilehack $(DESTDIR)/sbin
+ install write_proc hard-reboot $(DESTDIR)/sbin
++ test -d $(DESTDIR)/bin || mkdir -p $(DESTDIR)/bin
+ install msvc $(DESTDIR)/bin
+- test -d $(DESTDIR)/etc/minit || mkdir $(DESTDIR)/etc/minit
++ test -d $(DESTDIR)/etc/minit || mkdir -p $(DESTDIR)/etc/minit
+
+ install-fifos:
+ -mkfifo -m 600 $(DESTDIR)/etc/minit/in $(DESTDIR)/etc/minit/out
diff --git a/sys-process/minit/files/minit-0.10-fixes.diff b/sys-process/minit/files/minit-0.10-fixes.diff
new file mode 100644
index 000000000000..5c80091f84f3
--- /dev/null
+++ b/sys-process/minit/files/minit-0.10-fixes.diff
@@ -0,0 +1,62 @@
+diff -ru minit-0.10.orig/Makefile minit-0.10/Makefile
+--- minit-0.10.orig/Makefile 2005-04-08 19:24:04.000000000 +0200
++++ minit-0.10/Makefile 2008-11-27 23:05:57.000000000 +0100
+@@ -7,7 +7,7 @@
+ CROSS=
+ #CROSS=arm-linux-
+ LDFLAGS=-s
+-MANDIR=/usr/man
++MANDIR=/usr/share/man
+
+ path = $(subst :, ,$(PATH))
+ diet_path = $(foreach dir,$(path),$(wildcard $(dir)/diet))
+@@ -44,9 +44,11 @@
+ msvc: msvc.o
+ minit-update: minit-update.o split.o openreadclose.o
+ serdo: serdo.o
+-
+ shutdown: shutdown.o split.o openreadclose.o opendevconsole.o
+- $(DIET) $(CROSS)$(CC) $(LDFLAGS) -o shutdown $^
++pidfilehack: pidfilehack.o
++hard-reboot: hard-reboot.o
++write_proc: write_proc.o
++killall5: killall5.o
+
+ %.o: %.c
+ $(DIET) $(CROSS)$(CC) $(CFLAGS) -c $<
+@@ -61,22 +63,11 @@
+ test: test.c
+ gcc -nostdlib -o $@ $^ -I../dietlibc/include ../dietlibc/start.o ../dietlibc/dietlibc.a
+
+-pidfilehack: pidfilehack.c
+- $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+-
+-hard-reboot: hard-reboot.c
+- $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+-
+-write_proc: write_proc.c
+- $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+-
+-killall5: killall5.c
+- $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+-
+ install-files:
+ install -d $(DESTDIR)/etc/minit $(DESTDIR)/sbin $(DESTDIR)/bin $(DESTDIR)$(MANDIR)/man8
+- install minit pidfilehack $(DESTDIR)/sbin
++ install minit killall5 pidfilehack $(DESTDIR)/sbin
+ install write_proc hard-reboot minit-update $(DESTDIR)/sbin
++ install listpids $(DESTDIR)/sbin/minit-list
+ install msvc serdo $(DESTDIR)/bin
+ install -m 4750 shutdown $(DESTDIR)/sbin
+ test -f $(DESTDIR)/sbin/init || ln $(DESTDIR)/sbin/minit $(DESTDIR)/sbin/init
+diff -ru minit-0.10.orig/serdo.c minit-0.10/serdo.c
+--- minit-0.10.orig/serdo.c 2005-02-26 18:00:22.000000000 +0100
++++ minit-0.10/serdo.c 2008-11-27 23:02:57.000000000 +0100
+@@ -10,6 +10,7 @@
+ #define MAXENV 256
+ char* envp[MAXENV+2];
+ int envc;
++extern char **environ;
+
+ int continueonerror;
+