summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-04-23 16:12:32 -0500
committerTim Harder <radhermit@gentoo.org>2019-04-23 16:13:16 -0500
commit9f316ec42e3234a6a9f5183569426a96fe876cc8 (patch)
tree70a44a871aa3802a3b3bc88129a365f06de57832 /sys-process/parallel/parallel-20190422.ebuild
parentdev-python/pycairo: version bump to 1.18.1 (diff)
downloadgentoo-9f316ec42e3234a6a9f5183569426a96fe876cc8.tar.gz
gentoo-9f316ec42e3234a6a9f5183569426a96fe876cc8.tar.bz2
gentoo-9f316ec42e3234a6a9f5183569426a96fe876cc8.zip
sys-process/parallel: version bump to 20190422
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-process/parallel/parallel-20190422.ebuild')
-rw-r--r--sys-process/parallel/parallel-20190422.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-process/parallel/parallel-20190422.ebuild b/sys-process/parallel/parallel-20190422.ebuild
new file mode 100644
index 000000000000..2ff42c43ef5d
--- /dev/null
+++ b/sys-process/parallel/parallel-20190422.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-lang/perl:=
+ dev-perl/Devel-Size
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO"
+DEPEND="${RDEPEND}"
+
+DOCS="NEWS README"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # See src/Makefile.am for this one:
+ rm -f "${ED}"/usr/bin/sem || die
+ dosym ${PN} /usr/bin/sem
+}
+
+pkg_postinst() {
+ elog "To distribute jobs to remote machines you'll need these dependencies"
+ elog " net-misc/openssh"
+ elog " net-misc/rsync"
+}