summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-16 01:18:08 +0100
committerSam James <sam@gentoo.org>2023-06-16 01:18:08 +0100
commit8da3175374fcae0eae525689ab64e4554ed44572 (patch)
tree3524ec7e330cf4b207b9ce2f8aee809dbb68ec0c /sys-process/procs
parentsys-process/procs: new package, add 0.14.0 (diff)
downloadgentoo-8da3175374fcae0eae525689ab64e4554ed44572.tar.gz
gentoo-8da3175374fcae0eae525689ab64e4554ed44572.tar.bz2
gentoo-8da3175374fcae0eae525689ab64e4554ed44572.zip
sys-process/procs: install completions
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/procs')
-rw-r--r--sys-process/procs/procs-0.14.0-r1.ebuild (renamed from sys-process/procs/procs-0.14.0.ebuild)17
1 files changed, 16 insertions, 1 deletions
diff --git a/sys-process/procs/procs-0.14.0.ebuild b/sys-process/procs/procs-0.14.0-r1.ebuild
index ca275a7bff1c..32619a312107 100644
--- a/sys-process/procs/procs-0.14.0.ebuild
+++ b/sys-process/procs/procs-0.14.0-r1.ebuild
@@ -236,7 +236,7 @@ CRATES="
xattr-0.2.3
"
-inherit cargo
+inherit bash-completion-r1 cargo
DESCRIPTION="A modern replacement for ps"
HOMEPAGE="https://github.com/dalance/procs"
@@ -252,3 +252,18 @@ SLOT="0"
KEYWORDS="~amd64"
QA_FLAGS_IGNORED="usr/bin/procs"
+
+src_install() {
+ cargo_src_install
+
+ target/$(usex debug debug release)/procs --gen-completion bash || die
+ newbashcomp procs.bash procs
+
+ target/$(usex debug debug release)/procs --gen-completion zsh || die
+ insinto /usr/share/zsh/site-functions
+ doins _procs
+
+ target/$(usex debug debug release)/procs --gen-completion fish || die
+ insinto /usr/share/fish/vendor_completions.d
+ doins procs.fish
+}