summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/runit/runit-2.1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/runit/runit-2.1.2.ebuild')
-rw-r--r--sys-process/runit/runit-2.1.2.ebuild146
1 files changed, 146 insertions, 0 deletions
diff --git a/sys-process/runit/runit-2.1.2.ebuild b/sys-process/runit/runit-2.1.2.ebuild
new file mode 100644
index 000000000000..6e28dc4ae098
--- /dev/null
+++ b/sys-process/runit/runit-2.1.2.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic versionator
+
+DESCRIPTION="A UNIX init scheme with service supervision"
+HOMEPAGE="http://smarden.org/runit/"
+SRC_URI="http://smarden.org/runit/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+S=${WORKDIR}/admin/${P}/src
+
+src_prepare() {
+ # we either build everything or nothing static
+ sed -i -e 's:-static: :' Makefile
+
+ # see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=726008
+ [[ ${COMPILER} == "diet" ]] &&
+ use ppc &&
+ filter-flags "-mpowerpc-gpopt"
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ into /
+ dobin $(<../package/commands)
+ dodir /sbin
+ mv "${ED}"/bin/{runit-init,runit,utmpset} "${ED}"/sbin/ || die "dosbin"
+ dosym ../etc/runit/2 /sbin/runsvdir-start
+ into /usr
+
+ cd ..
+ dodoc package/{CHANGES,README,THANKS,TODO}
+ dohtml doc/*.html
+ doman man/*.[18]
+
+dodir /etc/runit
+ exeinto /etc/runit
+ doexe "${FILESDIR}"/{1,ctrlaltdel}
+ newexe "${FILESDIR}"/2-${PV} 2
+ newexe "${FILESDIR}"/3-${PV} 3
+
+ dodir /etc/sv
+ for tty in tty1 tty2 tty3 tty4 tty5 tty6; do
+ exeinto /etc/sv/getty-$tty/
+ newexe "${FILESDIR}"/finish.getty finish
+ newexe "${FILESDIR}"/run.getty-${PV} run
+ for script in finish run; do
+ sed -i -e "s:TTY:${tty}:g" "${ED}"/etc/sv/getty-$tty/$script
+ done
+ done
+
+ # make sv command work
+ cat <<-EOF > "${T}"/env.d
+ #/etc/env.d/20runit
+ SVDIR="/etc/service/"
+ EOF
+ insinto /etc/env.d
+ newins "${T}"/env.d 20runit
+}
+
+pkg_preinst() {
+ if has_version 'sys-process/runit' &&
+ has_version '<sys-process/runit-2.1.2' &&
+ [ -d "${EROOT}"etc/runit/runsvdir/all ]; then
+ if [ -e "${EROOT}"etc/sv ]; then
+ mv -f "${EROOT}"etc/sv "${EROOT}"etc/sv.bak || die
+ ewarn "${EROOT}etc/sv was moved to ${EROOT}etc/sv.bak"
+ fi
+ mv "${EROOT}"etc/runit/runsvdir/all "${EROOT}"etc/sv|| die
+ ln -sf "${EROOT}"etc/sv "${EROOT}"etc/runit/runsvdir/all || die
+ cp -a "${EROOT}"etc/runit/runsvdir "${T}" || die
+ touch "${T}"/make_var_service || die
+ fi
+}
+
+default_config() {
+ local sv="${EROOT}"etc/sv
+ local service="${EROOT}"etc/service
+ mkdir -p "${service}" || die
+ for x in tty1 tty2 tty3 tty4 tty5 tty6; do
+ ln -sf "${sv}"/getty-$x "${service}"/getty-$x || die
+ done
+ einfo "The links to services runit will supervise are installed"
+ einfo "in $service."
+ einfo "If you need multiple runlevels, please see the documentation"
+ einfo "for how to set them up."
+ einfo
+}
+
+migrate_from_211() {
+ # Create /etc/service and /var/service if requested
+ if [ -e "${T}"/make_var_service ]; then
+ ln -sf "${EROOT}"etc/runit/runsvdir/current "${EROOT}"etc/service || die
+ ln -sf "${EROOT}"etc/runit/runsvdir/current "${EROOT}"var/service || die
+ fi
+ if [ -d "${T}"/runsvdir ]; then
+ cp -a "${T}"/runsvdir "${EROOT}"etc/runit || die
+ fi
+ return 0
+}
+
+pkg_postinst() {
+ if [ -z "$REPLACING_VERSIONS" ]; then
+ default_config
+ elif [ ! version_is_at_least 2.1.2 $REPLACING_VERSIONS ]; then
+ migrate_from_211
+ fi
+
+ ewarn "To make sure sv works correctly in your currently open"
+ ewarn "shells, please run the following command:"
+ ewarn
+ ewarn "source /etc/profile"
+ ewarn
+
+ if [ -L "${EROOT}"var/service ]; then
+ ewarn "Once this version of runit is active, please remove the"
+ ewarn "compatibility symbolic link at ${EROOT}var/service"
+ ewarn "The correct path now is ${EROOT}etc/service"
+ ewarn
+ fi
+
+ if [ -L "${EROOT}"etc/runit/runsvdir/all ]; then
+ ewarn "${EROOT}etc/runit/runsvdir/all has moved to"
+ iewarn "${EROOT}etc/sv."
+ ewarn "Any symbolic links under ${EROOT}etc/runit/runsvdir"
+ ewarn "which point to services through ../all should be updated to"
+ ewarn "point to them through ${EROOT}etc/sv."
+ ewarn "Once that is done, ${EROOT}etc/runit/runsvdir/all should be"
+ ewarn "removed."
+ ewarn
+ fi
+}