summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2016-06-05 06:59:10 -0400
committerRichard Freeman <rich0@gentoo.org>2016-06-05 06:59:38 -0400
commitde912338b44d1f7d96c81fcf85e21d8f7fa7d7a4 (patch)
tree59bd86a265513c489d7a6cb738693c2e7042087b /sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
parentsys-process/systemd-cron: Shorten description (diff)
downloadgentoo-de912338b44d1f7d96c81fcf85e21d8f7fa7d7a4.tar.gz
gentoo-de912338b44d1f7d96c81fcf85e21d8f7fa7d7a4.tar.bz2
gentoo-de912338b44d1f7d96c81fcf85e21d8f7fa7d7a4.zip
sys-process/systemd-cron: bump
Bug: 578574 Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-process/systemd-cron/systemd-cron-1.5.4.ebuild')
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.4.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
new file mode 100644
index 000000000000..b759b3568ebc
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-1.5.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( pypy3 python{3_3,3_4} )
+inherit eutils python-single-r1 systemd
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely setgid yearly"
+
+RDEPEND=">=sys-apps/systemd-217
+ sys-apps/debianutils
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ ${PYTHON_DEPS}
+ sys-process/cronbase"
+
+DEPEND="sys-process/cronbase"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ python_fix_shebang --force "${S}/src/bin"
+
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+ -- "${S}/src/man/crontab."{1,5}".in" || die
+
+ sed -i \
+ -e 's!/crontab$!/crontab-systemd!' \
+ -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
+ -- "${S}/Makefile.in" || die
+
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.py" || die
+ fi
+
+ epatch_user
+}
+
+my_use_enable() {
+ if use ${1}; then
+ echo --enable-${2:-${1}}=yes
+ else
+ echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --confdir="${EPREFIX}/etc" \
+ --runparts="${EPREFIX}/bin/run-parts" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_unitdir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable minutely) \
+ $(my_use_enable yearly) \
+ $(my_use_enable yearly quarterly) \
+ $(my_use_enable yearly semi_annually) \
+ $(my_use_enable setgid) \
+ --enable-persistent=yes
+}