summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-07-14 08:28:57 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-07-14 08:28:57 +0300
commit999ce663d8a28b414d6b41515b7f1c04f17ad225 (patch)
tree9b71663d7207fe68db623cc21928118ce65a33ff /sys-process/uksmd/files
parentdev-libs/dqlite: drop 1.11.0 (diff)
downloadgentoo-999ce663d8a28b414d6b41515b7f1c04f17ad225.tar.gz
gentoo-999ce663d8a28b414d6b41515b7f1c04f17ad225.tar.bz2
gentoo-999ce663d8a28b414d6b41515b7f1c04f17ad225.zip
sys-process/uksmd: patch out automagic dep for systemd
- and always install the service file. Automagic would be harmful when switching between init systems on an existing installation, from openrc to systemd. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-process/uksmd/files')
-rw-r--r--sys-process/uksmd/files/uksmd-0-remove-systemd-dep.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/uksmd/files/uksmd-0-remove-systemd-dep.patch b/sys-process/uksmd/files/uksmd-0-remove-systemd-dep.patch
new file mode 100644
index 000000000000..6940f78e4662
--- /dev/null
+++ b/sys-process/uksmd/files/uksmd-0-remove-systemd-dep.patch
@@ -0,0 +1,32 @@
+diff -Naur a/meson.build b/meson.build
+--- a/meson.build 2022-07-08 23:53:08.000000000 +0300
++++ b/meson.build 2022-07-14 08:12:38.358174169 +0300
+@@ -13,28 +13,6 @@
+ dependency('libcap-ng'),
+ ]
+
+-systemd = dependency('systemd', required: false)
+-
+-if systemd.found()
+- systemd_system_unit_dir = systemd.get_pkgconfig_variable('systemdsystemunitdir')
+- unit_files = [
+- 'uksmd.service'
+- ]
+-
+-
+- foreach u: unit_files
+- configure_file(
+- copy: true,
+- input: u,
+- install: true,
+- install_dir: systemd_system_unit_dir,
+- output: u,
+- )
+- endforeach
+-
+- project_dependencies += systemd
+-endif
+-
+ build_args = [
+ '-DPROJECT_NAME=' + meson.project_name(),
+ '-DPROJECT_VERSION=' + meson.project_version(),