summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 11:04:58 -0500
committerMikle Kolyada <zlogene@gentoo.org>2018-04-23 17:53:17 +0300
commitf04018ad352989d27434700fecc8108a917f2ff5 (patch)
treec8fd07ae9fa397e50921198723be14a3c3ba97db /sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
parentsys-devel/gdb-apple: epatch->PATCHES=() (diff)
downloadgentoo-f04018ad352989d27434700fecc8108a917f2ff5.tar.gz
gentoo-f04018ad352989d27434700fecc8108a917f2ff5.tar.bz2
gentoo-f04018ad352989d27434700fecc8108a917f2ff5.zip
sys-process/unixtop: epatch->PATCHES=()
Reworked patches to be -p1, and converted the two 'diff -c' context style diffs to a 'diff -u' unified diff, both for greater readability and a generally smaller filesize. Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild')
-rw-r--r--sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild b/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
index d32e3863a6f7..c4f9598cf00b 100644
--- a/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
+++ b/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils autotools
+inherit autotools
DESCRIPTION="top for UNIX systems"
HOMEPAGE="http://unixtop.sourceforge.net/"
@@ -19,14 +19,17 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/top-${PV/_/}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.8_beta1-ncurses.patch
+ "${FILESDIR}"/${PN}-3.8_beta1-no-AX-macros.patch
+ "${FILESDIR}"/${PN}-3.8_beta1-renice-segfault.patch
+ "${FILESDIR}"/${PN}-3.8_beta1-memleak-fix-v2.patch
+ "${FILESDIR}"/${PN}-3.8_beta1-high-threadid-crash.patch
+ "${FILESDIR}"/${PN}-3.8_beta1-percent-cpu.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-ncurses.patch
- epatch "${FILESDIR}"/${P}-no-AX-macros.patch
- epatch "${FILESDIR}"/${P}-renice-segfault.patch
- epatch "${FILESDIR}"/${P}-memleak-fix-v2.patch
- epatch "${FILESDIR}"/${P}-high-threadid-crash.patch
- epatch "${FILESDIR}"/${P}-percent-cpu.patch
- eapply_user
+ default
eautoreconf
}