summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-08-24 03:55:14 +0000
committerZero_Chaos <zerochaos@gentoo.org>2018-08-24 03:55:28 +0000
commit5092d2c6d710c654fc271dd434e260f034597d50 (patch)
treeb60cc31dfc9c549397bb7b367d8c2d14c404d817 /sys-process/usbtop/usbtop-0.2.ebuild
parentx11-libs/libX11: mark s390 stable (diff)
downloadgentoo-5092d2c6d710c654fc271dd434e260f034597d50.tar.gz
gentoo-5092d2c6d710c654fc271dd434e260f034597d50.tar.bz2
gentoo-5092d2c6d710c654fc271dd434e260f034597d50.zip
sys-process/usbtop: initial commit
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-process/usbtop/usbtop-0.2.ebuild')
-rw-r--r--sys-process/usbtop/usbtop-0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/usbtop/usbtop-0.2.ebuild b/sys-process/usbtop/usbtop-0.2.ebuild
new file mode 100644
index 000000000000..2661c02577d9
--- /dev/null
+++ b/sys-process/usbtop/usbtop-0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="utility that shows an estimated instantaneous bandwidth on USB buses and devices"
+HOMEPAGE="https://github.com/aguinet/usbtop"
+SRC_URI="https://github.com/aguinet/usbtop/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap:=[usb]
+ dev-libs/boost:=[threads]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="~USB_MON"
+ check_extra_config
+ fi
+}