summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-17 03:18:39 +0100
committerSam James <sam@gentoo.org>2022-06-17 13:10:06 +0100
commit12cfa36a4545d0cadbbb7e5cfb7f384ef0a44edc (patch)
treedd5e02c9b3aa34ddfadc444b89fc65a8ee50122c /sys-process
parentsys-process/nmon: add 16n (diff)
downloadgentoo-12cfa36a4545d0cadbbb7e5cfb7f384ef0a44edc.tar.gz
gentoo-12cfa36a4545d0cadbbb7e5cfb7f384ef0a44edc.tar.bz2
gentoo-12cfa36a4545d0cadbbb7e5cfb7f384ef0a44edc.zip
sys-process/numactl: allow LTO; drop -arm
- Allow LTO (fixed upsteam in 2.0.14) - Drop -arm (see https://github.com/numactl/numactl/commit/e13c9a8417360b16a586226f3b80db0d0aebc248). Closes: https://bugs.gentoo.org/692254 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/numactl-2.0.14-r1.ebuild68
-rw-r--r--sys-process/numactl/numactl-9999.ebuild19
2 files changed, 76 insertions, 11 deletions
diff --git a/sys-process/numactl/numactl-2.0.14-r1.ebuild b/sys-process/numactl/numactl-2.0.14-r1.ebuild
new file mode 100644
index 000000000000..8effff8d7343
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.14-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="https://github.com/numactl/numactl"
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numactl/numactl.git"
+else
+ SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.14-latomic.patch
+ "${FILESDIR}"/${PN}-2.0.14-numademo-cflags.patch # bug #540856
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # We need to copy the sources or else tests will fail
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ multilib_is_native_abi && default || emake libnuma.la
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ if [[ -d /sys/devices/system/node ]] ; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ emake regress2
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
+ find "${ED}"/usr/ -type f -name libnuma.la -delete || die
+}
+
+multilib_src_install_all() {
+ local DOCS=( README.md )
+ einstalldocs
+
+ # Delete man pages provided by the man-pages package, bug #238805
+ rm -r "${ED}"/usr/share/man/man[25] || die
+}
diff --git a/sys-process/numactl/numactl-9999.ebuild b/sys-process/numactl/numactl-9999.ebuild
index 52aa4083497c..3dc7b156a4cc 100644
--- a/sys-process/numactl/numactl-9999.ebuild
+++ b/sys-process/numactl/numactl-9999.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools flag-o-matic multilib-minimal
+inherit autotools multilib-minimal
DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="https://github.com/numactl/numactl"
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/numactl/numactl.git"
else
SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
- # ARM lacks the __NR_migrate_pages syscall.
- KEYWORDS="~amd64 -arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~x86 ~amd64-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
fi
LICENSE="GPL-2"
@@ -21,17 +20,14 @@ SLOT="0"
IUSE="static-libs"
PATCHES=(
- "${FILESDIR}"/${PN}-2.0.10-numademo-cflags.patch #540856
+ "${FILESDIR}"/${PN}-2.0.14-numademo-cflags.patch # bug #540856
)
src_prepare() {
default
- # lto not supported yet
- # gcc-9 with -flto leads to link failures: #692254
- filter-flags -flto*
-
eautoreconf
+
# We need to copy the sources or else tests will fail
multilib_copy_sources
}
@@ -65,6 +61,7 @@ multilib_src_install() {
multilib_src_install_all() {
local DOCS=( README.md )
einstalldocs
- # delete man pages provided by the man-pages package #238805
+
+ # Delete man pages provided by the man-pages package, bug #238805
rm -r "${ED}"/usr/share/man/man[25] || die
}