summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-19 23:42:28 +0100
committerSam James <sam@gentoo.org>2023-07-19 23:42:28 +0100
commit1e505057e5ec18ae8b98d22d9cf1955ce0a46fad (patch)
tree41daff26a7d988f96909db131209e285cf947057 /sys-process
parentsys-devel/gdb: add debuginfod support (diff)
downloadgentoo-1e505057e5ec18ae8b98d22d9cf1955ce0a46fad.tar.gz
gentoo-1e505057e5ec18ae8b98d22d9cf1955ce0a46fad.tar.bz2
gentoo-1e505057e5ec18ae8b98d22d9cf1955ce0a46fad.zip
sys-process/lsof: backport strftime fix
Closes: https://bugs.gentoo.org/910547 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/lsof/files/lsof-4.98.0-fix-common-include-strftime.patch28
-rw-r--r--sys-process/lsof/lsof-4.98.0-r1.ebuild58
2 files changed, 86 insertions, 0 deletions
diff --git a/sys-process/lsof/files/lsof-4.98.0-fix-common-include-strftime.patch b/sys-process/lsof/files/lsof-4.98.0-fix-common-include-strftime.patch
new file mode 100644
index 000000000000..4b22dbfb8a02
--- /dev/null
+++ b/sys-process/lsof/files/lsof-4.98.0-fix-common-include-strftime.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/910547
+https://github.com/lsof-org/lsof/commit/437824cf35daf5a505bed5b619bef95af090ecc4
+
+From 437824cf35daf5a505bed5b619bef95af090ecc4 Mon Sep 17 00:00:00 2001
+From: Kalin KOZHUHAROV <me.kalin@gmail.com>
+Date: Wed, 19 Jul 2023 15:23:13 +0200
+Subject: [PATCH] src/util.c add proper includes (#294)
+
+* src/util.c add proper includes
+
+Fixes #293 for lsof-org/lsof
+
+Signed-off-by: Kalin KOZHUHAROV <kalin@thinrope.net>
+
+---------
+
+Signed-off-by: Kalin KOZHUHAROV <kalin@thinrope.net>
+Co-authored-by: Jiajie Chen <c@jia.je>
+--- a/util.c
++++ b/util.c
+@@ -35,6 +35,7 @@
+ * 4. This notice may not be removed or altered.
+ */
+
++#include "lsof.h"
+
+ #if defined(HAS_STRFTIME)
+ #include <time.h>
diff --git a/sys-process/lsof/lsof-4.98.0-r1.ebuild b/sys-process/lsof/lsof-4.98.0-r1.ebuild
new file mode 100644
index 000000000000..aef7b5fff4a8
--- /dev/null
+++ b/sys-process/lsof/lsof-4.98.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+MY_P="${P/-/_}"
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="https://github.com/lsof-org/lsof"
+SRC_URI="https://github.com/lsof-org/lsof/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rpc selinux"
+
+RDEPEND="
+ rpc? ( net-libs/libtirpc )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-apps/groff
+ rpc? ( virtual/pkgconfig )
+"
+
+# Needs fixing first for sandbox
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-common-include-strftime.patch
+)
+
+src_configure() {
+ # TODO: drop after 4.98.0: https://github.com/lsof-org/lsof/commit/4fbe0b78f63ce115f25cf7a49756745e3bf47fea
+ export ac_cv_header_selinux_selinux_h=$(usex selinux)
+
+ # TODO: drop after 4.98.0: https://github.com/lsof-org/lsof/commit/22d9cedfca4672601f35f7683907373cd5124121
+ [[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX
+
+ local myeconfargs=(
+ $(use_with rpc libtirpc)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake DEBUG="" all
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "Note: to use lsof on Solaris you need read permissions on"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
+ fi
+}