summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-09-02 12:37:36 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-09-02 12:37:36 +0200
commit271730228bb4d0f0e824a3c9755ed9d178054198 (patch)
tree703d0fc7a5685f0a42ea5c579ad345f26d2d466f /sys-process
parentsys-process/numactl: Removed old (diff)
downloadgentoo-271730228bb4d0f0e824a3c9755ed9d178054198.tar.gz
gentoo-271730228bb4d0f0e824a3c9755ed9d178054198.tar.bz2
gentoo-271730228bb4d0f0e824a3c9755ed9d178054198.zip
sys-process/numactl: disable -flto
Bug: https://bugs.gentoo.org/692254 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/numactl-2.0.12.ebuild9
-rw-r--r--sys-process/numactl/numactl-2.0.13.ebuild7
-rw-r--r--sys-process/numactl/numactl-9999.ebuild7
3 files changed, 19 insertions, 4 deletions
diff --git a/sys-process/numactl/numactl-2.0.12.ebuild b/sys-process/numactl/numactl-2.0.12.ebuild
index 382d2e6496e8..76fe335d6730 100644
--- a/sys-process/numactl/numactl-2.0.12.ebuild
+++ b/sys-process/numactl/numactl-2.0.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools toolchain-funcs multilib-minimal
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="https://github.com/numactl/numactl"
@@ -26,6 +26,11 @@ PATCHES=(
src_prepare() {
default
+
+ # lto not supported yet
+ # gcc-9 with -flto leads to link failures: #692254
+ filter-flags -flto*
+
eautoreconf
# We need to copy the sources or else tests will fail
multilib_copy_sources
diff --git a/sys-process/numactl/numactl-2.0.13.ebuild b/sys-process/numactl/numactl-2.0.13.ebuild
index e38e4a774774..6bcda4fcddba 100644
--- a/sys-process/numactl/numactl-2.0.13.ebuild
+++ b/sys-process/numactl/numactl-2.0.13.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools toolchain-funcs multilib-minimal
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="https://github.com/numactl/numactl"
@@ -26,6 +26,11 @@ PATCHES=(
src_prepare() {
default
+
+ # lto not supported yet
+ # gcc-9 with -flto leads to link failures: #692254
+ filter-flags -flto*
+
eautoreconf
# We need to copy the sources or else tests will fail
multilib_copy_sources
diff --git a/sys-process/numactl/numactl-9999.ebuild b/sys-process/numactl/numactl-9999.ebuild
index e38e4a774774..6bcda4fcddba 100644
--- a/sys-process/numactl/numactl-9999.ebuild
+++ b/sys-process/numactl/numactl-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools toolchain-funcs multilib-minimal
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Utilities and libraries for NUMA systems"
HOMEPAGE="https://github.com/numactl/numactl"
@@ -26,6 +26,11 @@ PATCHES=(
src_prepare() {
default
+
+ # lto not supported yet
+ # gcc-9 with -flto leads to link failures: #692254
+ filter-flags -flto*
+
eautoreconf
# We need to copy the sources or else tests will fail
multilib_copy_sources