summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2023-12-25 16:57:40 +0000
committerSam James <sam@gentoo.org>2024-01-04 00:05:55 +0000
commit4672163358ac5fdff3470273352a892cc13d3934 (patch)
treed631800337d60414505b7e99a93b802d0e2b06d1 /sys-process
parentprofiles/targets/desktop: add dev-util/cmake[-qt6] (diff)
downloadgentoo-4672163358ac5fdff3470273352a892cc13d3934.tar.gz
gentoo-4672163358ac5fdff3470273352a892cc13d3934.tar.bz2
gentoo-4672163358ac5fdff3470273352a892cc13d3934.zip
sys-process/lsof: do not install libtool .la files
Closes: https://bugs.gentoo.org/920370 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/lsof/lsof-4.99.0.ebuild5
-rw-r--r--sys-process/lsof/lsof-4.99.3.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/sys-process/lsof/lsof-4.99.0.ebuild b/sys-process/lsof/lsof-4.99.0.ebuild
index c94a98abca1d..d1dba0173182 100644
--- a/sys-process/lsof/lsof-4.99.0.ebuild
+++ b/sys-process/lsof/lsof-4.99.0.ebuild
@@ -39,6 +39,11 @@ src_compile() {
emake DEBUG="" all
}
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
pkg_postinst() {
if [[ ${CHOST} == *-solaris* ]] ; then
einfo "Note: to use lsof on Solaris you need read permissions on"
diff --git a/sys-process/lsof/lsof-4.99.3.ebuild b/sys-process/lsof/lsof-4.99.3.ebuild
index 9965531bc30b..c22f1df517e3 100644
--- a/sys-process/lsof/lsof-4.99.3.ebuild
+++ b/sys-process/lsof/lsof-4.99.3.ebuild
@@ -39,6 +39,11 @@ src_compile() {
emake DEBUG="" all
}
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
pkg_postinst() {
if [[ ${CHOST} == *-solaris* ]] ; then
einfo "Note: to use lsof on Solaris you need read permissions on"