summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-15 02:20:49 +0000
committerSam James <sam@gentoo.org>2022-05-15 02:37:42 +0000
commit514b8fd5881118af60f193b9035884dbee258339 (patch)
tree58d11957b903f62a0f8041c89bb6cd2d9bad2e1d /sys-process
parentapp-containers/img: update EAPI 7 -> 8; use vendor dir (diff)
downloadgentoo-514b8fd5881118af60f193b9035884dbee258339.tar.gz
gentoo-514b8fd5881118af60f193b9035884dbee258339.tar.bz2
gentoo-514b8fd5881118af60f193b9035884dbee258339.zip
sys-process/ctop: add 0.7.7
Bug: https://bugs.gentoo.org/844526 Bug: https://bugs.gentoo.org/679606 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/ctop/Manifest2
-rw-r--r--sys-process/ctop/ctop-0.7.7.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/sys-process/ctop/Manifest b/sys-process/ctop/Manifest
index e62c0e1a54d0..117163543319 100644
--- a/sys-process/ctop/Manifest
+++ b/sys-process/ctop/Manifest
@@ -1,4 +1,6 @@
DIST ctop-0.7.3.tar.gz 1280840 BLAKE2B ed0707882e402867bc0e306721ae4723d653f894c5725178db1dea2c99b68793339a174116ac0f34cc428171918696348c602a971dfa70af70b2e923d0f00428 SHA512 4f2a44792ab94e4de5dac9c09177e7ce8f4076ae69f1a42bfd5cb7120b10288105ecbbda133da611ab84f03a7c32de74f369135c1d9a2dc83d85b4506ceae878
+DIST ctop-0.7.7-deps.tar.xz 68739556 BLAKE2B 2e362942f5cb37ae8b7d17b802afac7d6ffef1ec21239ab86a3ec63c83975fb6fd8188a7d8ec144ff6c577ac645447e1f6f44791e8795b4f20ef74bc7b037772 SHA512 6eb8102ccaf227bcd5b415f345320782389cbdfda38e2d9dda6713e59020848feb9b568241bf948daeb691d0951e6cf45a0b72cd272db95a03a2482d4eb2f599
+DIST ctop-0.7.7.tar.gz 1434567 BLAKE2B 21bcc7a7996cf8cd1bfb87da30bbccd3f1c9a257b1140a81795186c466c7e499233e691eca3dac2e953fb9e46d0cacd78ee87abcbfd01965401d3666f3ff8eff SHA512 9924c4dc5da489f90b029bc8060e759edf02a170e17bbc9f9c29b6536e5bc3e5eec69af829c7662a1f69cd331fc24022cae8b30e865a07742fd7e3623bc7f33f
DIST github.com%2F!azure%2Fgo-ansiterm%2F@v%2Fv0.0.0-20170929234023-d6e3b3328b78.mod 36 BLAKE2B 52a2c5272e004524397df00dfa03b4c2d2ebd985a0c974236aad6b847d6b2b4b7c9b69ef48e263f4c67983b845b020d2004fe749b46fee3c0525da0416b20f3e SHA512 350a16c68553738ce8c2f4a6ac8beba66a7dcf2386a42aff938ebaa3bdc526bda8e5c51c493331eda4666cbcf8411ee7ca3aeb0768cc4f557f34585960f9eb84
DIST github.com%2F!azure%2Fgo-ansiterm%2F@v%2Fv0.0.0-20170929234023-d6e3b3328b78.zip 32735 BLAKE2B 5de266d7400ae80c027f209cea91c911e22b0ff4fc6a2e964e8906f1a86cc6905b9c12d2588d5fdc91d0d8e9501a0ddf2f7a376cca9935d21943386c3ef31979 SHA512 72621865ffc0cadd27603e2f4032f1cd9c9d8bdcb920b3ca9fd02dbf88e52876a6f092c5b74eceb136021c514b68dc599f0cbbf18ed1620b827d46462aa55e32
DIST github.com%2F!burnt!sushi%2Ftoml%2F@v%2Fv0.3.0.mod 34 BLAKE2B ce54a247aef91043830bdf0603c8452ba38eceb1495af6e7a74c9119234a0dc5cd080cb25258c28f5e270acf91189a5ed33e361cbf17de2be5e37dadbda1d90d SHA512 320941bc3b7fb8bc595e6135cbc513a7583d129f0cd92508055291e141191066303cf75148e25198c21f6c6c539a790ea3210f3ecf5de6a2a03b70c753091146
diff --git a/sys-process/ctop/ctop-0.7.7.ebuild b/sys-process/ctop/ctop-0.7.7.ebuild
new file mode 100644
index 000000000000..bec6ba5b3f9f
--- /dev/null
+++ b/sys-process/ctop/ctop-0.7.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Top-like interface for container-metrics"
+HOMEPAGE="https://ctop.sh https://github.com/bcicen/ctop"
+SRC_URI="https://github.com/bcicen/ctop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hardened"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ emake VERSION="${PV}" BUILD="${PVR}" build
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.md
+}