summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-12 04:10:39 +0000
committerSam James <sam@gentoo.org>2023-11-12 04:10:53 +0000
commit668d113bf9ad3fe39bc15964900730dc869832f4 (patch)
tree327ed3bd794caefd5ba1ed1735470481dc59358a /sys-process
parentnet-misc/whois: add 5.5.20 (diff)
downloadgentoo-668d113bf9ad3fe39bc15964900730dc869832f4.tar.gz
gentoo-668d113bf9ad3fe39bc15964900730dc869832f4.tar.bz2
gentoo-668d113bf9ad3fe39bc15964900730dc869832f4.zip
sys-process/lsof: add 4.99.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/lsof/Manifest1
-rw-r--r--sys-process/lsof/lsof-4.99.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-process/lsof/Manifest b/sys-process/lsof/Manifest
index 7767d56a6339..a0c745e7e152 100644
--- a/sys-process/lsof/Manifest
+++ b/sys-process/lsof/Manifest
@@ -1 +1,2 @@
DIST lsof-4.98.0.tar.gz 734232 BLAKE2B 2f4ba4d179e8061e5bcff7dda4a0981616530bd5577fc73904e2699e6e982efee9e4270d3f2d3c68751d73cb98bfed0fd49d4c6bd967d15b4e06dcb72494d024 SHA512 6fde12497ce9cbba698be624b45e8392d551626c3e46b50ec23e661b322438ef7162dbac0d06829d56f074c7d934fa1ca98aa50ee1487125c93bebfe8eb2a2e8
+DIST lsof-4.99.0.tar.gz 1127302 BLAKE2B 257f84e01b9530ab3a6c637c13c8e84c2562fa3ecd9048f93e2816bbed36ffd529311bc1424a41cde72383642decbd6f44e680bfdd2594bbae5908b07c466165 SHA512 6fe3039f1167fb3023a7f358dda2b4ea6eace1e50a97d0168af494217581eef73cc1742f544d2fb9f85ded8370c86e63d48104da899396de7b3007997a201825
diff --git a/sys-process/lsof/lsof-4.99.0.ebuild b/sys-process/lsof/lsof-4.99.0.ebuild
new file mode 100644
index 000000000000..9965531bc30b
--- /dev/null
+++ b/sys-process/lsof/lsof-4.99.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P/-/_}"
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="https://github.com/lsof-org/lsof"
+SRC_URI="https://github.com/lsof-org/lsof/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rpc selinux"
+
+RDEPEND="
+ rpc? ( net-libs/libtirpc )
+ selinux? ( sys-libs/libselinux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-apps/groff
+ rpc? ( virtual/pkgconfig )
+"
+
+# Needs fixing first for sandbox
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with rpc libtirpc)
+ $(use_with selinux)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake DEBUG="" all
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "Note: to use lsof on Solaris you need read permissions on"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
+ fi
+}