summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2019-06-23 18:22:02 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-27 13:40:30 +0200
commit7fdc19210d626c8d625c05347ba3ae715325f1f1 (patch)
tree4e0b2cc96a5cbbe837cd23f586c183a94e8e0dd9 /sys-process
parentdev-libs/oniguruma: alpha stable wrt bug #688320 (diff)
downloadgentoo-7fdc19210d626c8d625c05347ba3ae715325f1f1.tar.gz
gentoo-7fdc19210d626c8d625c05347ba3ae715325f1f1.tar.bz2
gentoo-7fdc19210d626c8d625c05347ba3ae715325f1f1.zip
sys-process/evisum: bump to 0.2.3
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Joonas Niilola <juippis@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12311 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/evisum/Manifest1
-rw-r--r--sys-process/evisum/evisum-0.2.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/evisum/Manifest b/sys-process/evisum/Manifest
index b36aeb906432..14bb64d4cf0e 100644
--- a/sys-process/evisum/Manifest
+++ b/sys-process/evisum/Manifest
@@ -1,2 +1,3 @@
DIST evisum-0.2.0.tar.xz 84340 BLAKE2B ef950f9cab3e8b6e911a62e4a2338f4ce3b80b92c00a9d7a26c3e1929ad140d04dd46ecc96487205b07027a959f772ec2eb437509efdadffce7a496a2784391a SHA512 d0d071b652477f8e25a913d8424245e019f2b418de8886641b6a550845e59a5b55f4e5319530519834d8c699a8a4cdd1a6512271e321a53b1e6d64dc9700a40d
DIST evisum-0.2.2.tar.xz 84984 BLAKE2B f514faae5fa1286ebc862e7d58d406ebffa700a41be6c90576a91399abd83329ff0b271bdb964140e4cd698b8cf4fc1c7198b4dee9d2467b64a21013623ef193 SHA512 06fb235a61093c5aa33a8171418a80a94e311ebdbc362fc0229019e24e4e9d933a491fac94be49ca72180b5ce81b1cee133e46a75462527a343c67ba46fdffe9
+DIST evisum-0.2.3.tar.xz 85000 BLAKE2B 3f3a43ff569d05550d092930f1cf61eb4deef2a449bd1b407b0f460c15887b76fc430ecbbe8357e6a06d6c34cdce68321d38922635ec4b9caccad084d9c619d6 SHA512 0043432f2b434c2bbdbe03b96d29a3f9515d063bdf5ae61ef5273aad1ec6dbc532860af4a22bebf275f171585e793e3851eec9c98a7eaa4645e32d3a79eafdc1
diff --git a/sys-process/evisum/evisum-0.2.3.ebuild b/sys-process/evisum/evisum-0.2.3.ebuild
new file mode 100644
index 000000000000..9ea74684dde2
--- /dev/null
+++ b/sys-process/evisum/evisum-0.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="System and process monitor written with EFL"
+HOMEPAGE="https://www.enlightenment.org/"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/efl"
+RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.2.2-respect-cflags-ldflags.patch" )
+
+src_install() {
+ emake PREFIX="${D}"/usr install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}