summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-12-04 10:52:28 -0800
committerPatrick McLean <chutzpah@gentoo.org>2023-12-04 10:52:28 -0800
commit8ba6178def1a0070df7186160145645394ca8527 (patch)
tree54be85ed9acfb66c69835a294a716df52a43a8c6 /sys-process
parentapp-laptop/framework-laptop-kmod: add 0_pre20231204, drop 0_pre20231129 (diff)
downloadgentoo-8ba6178def1a0070df7186160145645394ca8527.tar.gz
gentoo-8ba6178def1a0070df7186160145645394ca8527.tar.bz2
gentoo-8ba6178def1a0070df7186160145645394ca8527.zip
sys-process/bpytop: enable py3.12
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/bpytop/bpytop-1.0.68-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-process/bpytop/bpytop-1.0.68-r1.ebuild b/sys-process/bpytop/bpytop-1.0.68-r1.ebuild
index 3656a5c1c26a..78fa09a9c613 100644
--- a/sys-process/bpytop/bpytop-1.0.68-r1.ebuild
+++ b/sys-process/bpytop/bpytop-1.0.68-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1
@@ -37,3 +37,10 @@ src_install() {
doins bpytop-themes/*.theme
distutils-r1_src_install
}
+
+python_test() {
+ EPYTEST_DESELECT=(
+ tests/test_functions.py::test_get_cpu_core_mapping
+ )
+ epytest
+}