summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-27 22:58:26 +0000
committerSam James <sam@gentoo.org>2024-02-27 23:00:18 +0000
commit9eb067ee3701d13567bb08ec06dea64ec874a278 (patch)
treeb7541a4d6c9e71551b8b6022640fbee8e3559762 /sys-process
parentsys-apps/moar: recreate Go dep tarball (diff)
downloadgentoo-9eb067ee3701d13567bb08ec06dea64ec874a278.tar.gz
gentoo-9eb067ee3701d13567bb08ec06dea64ec874a278.tar.bz2
gentoo-9eb067ee3701d13567bb08ec06dea64ec874a278.zip
sys-process/ctop: recreate Go dep tarball
Much smaller with the cached .zips dropped. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/ctop/Manifest2
-rw-r--r--sys-process/ctop/ctop-0.7.7.ebuild4
2 files changed, 4 insertions, 2 deletions
diff --git a/sys-process/ctop/Manifest b/sys-process/ctop/Manifest
index c7dada267937..8a2c55d7f091 100644
--- a/sys-process/ctop/Manifest
+++ b/sys-process/ctop/Manifest
@@ -1,2 +1,2 @@
-DIST ctop-0.7.7-deps.tar.xz 67561244 BLAKE2B ad8d6c2d57f3f224f635da86da4b3d696fd2ce486114fc6bcd9533e5b73a7318f8d2493f0e1753e94606ea3e6cf6bdd2306354924b3825259ccc957637de6fa2 SHA512 96c7acaf1b7651619d3384bf49564542694d723b5af4d65db43808888e901915329688be14ad48797df55d9aa5b00c2ae48a054d80d503f613a9c7cf9ddbf0ae
+DIST ctop-0.7.7-deps.tar.xz 23927548 BLAKE2B 3fc1aa33f13543c1c07eb841f89b6da7b32adac7b3ec3dbf8fdf84759de8a43ac125c3a9422f6cef474be8c65ea4aa1316d36a5de16d7a18e91cc9a2330192f7 SHA512 a7519946a7a31991fedc03a786e9a0cb52ddd1fa0afa2b7b73b44f65aeed7cf2ccd42dc4b4d0eb9de4fc9a90566576e2cfe3193d4520426aa9553d84c0e8702a
DIST ctop-0.7.7.tar.gz 1434567 BLAKE2B 21bcc7a7996cf8cd1bfb87da30bbccd3f1c9a257b1140a81795186c466c7e499233e691eca3dac2e953fb9e46d0cacd78ee87abcbfd01965401d3666f3ff8eff SHA512 9924c4dc5da489f90b029bc8060e759edf02a170e17bbc9f9c29b6536e5bc3e5eec69af829c7662a1f69cd331fc24022cae8b30e865a07742fd7e3623bc7f33f
diff --git a/sys-process/ctop/ctop-0.7.7.ebuild b/sys-process/ctop/ctop-0.7.7.ebuild
index bec6ba5b3f9f..6921a8a22a0f 100644
--- a/sys-process/ctop/ctop-0.7.7.ebuild
+++ b/sys-process/ctop/ctop-0.7.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,6 +16,8 @@ KEYWORDS="~amd64"
IUSE="hardened"
src_compile() {
+ sed -i -e '/go mod download/d' Makefile || die
+
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
emake VERSION="${PV}" BUILD="${PVR}" build
}