summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-08-14 21:01:31 -0400
committerMichael Orlitzky <mjo@gentoo.org>2019-08-14 21:01:51 -0400
commita3769d82e127646e75a8fa32d79e971ea5063aa8 (patch)
treeb1a2f897344b8fb1d0e47e423bbe07c86c5c62e4 /sys-process
parentprofiles/package.mask: for real now (diff)
downloadgentoo-a3769d82e127646e75a8fa32d79e971ea5063aa8.tar.gz
gentoo-a3769d82e127646e75a8fa32d79e971ea5063aa8.tar.bz2
gentoo-a3769d82e127646e75a8fa32d79e971ea5063aa8.zip
sys-process/xjobs: new version 20190725.
This version comes with a few fixes/improvements: * An update to EAPI=7. * A patch to fix the build against separate libtinfo (bug #689982). Upstream will include a similar fix in subsequent versions. * An unconditional build/runtime dependency on ncurses/libtinfo which are detected and used automagically by the build system. Bug: https://bugs.gentoo.org/689982 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/xjobs/Manifest1
-rw-r--r--sys-process/xjobs/files/search-libtinfo-for-tigetstr-and-tparm.patch32
-rw-r--r--sys-process/xjobs/xjobs-20190725.ebuild36
3 files changed, 69 insertions, 0 deletions
diff --git a/sys-process/xjobs/Manifest b/sys-process/xjobs/Manifest
index 90c00b2226c8..f6db8bc3c73e 100644
--- a/sys-process/xjobs/Manifest
+++ b/sys-process/xjobs/Manifest
@@ -1 +1,2 @@
DIST xjobs-20170829.tgz 109732 BLAKE2B 7c1db1b8bd5a382364d62093f7c28d4f6d13220c01b757c0f92fe1d20acdce699234e8e0c3fc98105a0e9cd93eb10738473ef95bb1e5bb64725155bc878bdb4e SHA512 9308c239ebf0dfa8374a85d753b2234c083b29e2b65b19028e5e67864df80df345ec232c13777cef8a21d3872408967a065fa8d54761b14a2f452b483b86f80c
+DIST xjobs-20190725.tgz 113216 BLAKE2B 079b6e104bb160101b2c4ef11e73ff040a8efa30839a39f9c91121b4928ddeefaefa43c3a94e18c9359fb6f66862ad7554598561a4e0c7f36b8f622d9a394340 SHA512 23ead9d33ebacb1b3d7a03c72c40dfb34b6254add81b0fde9e458a4be54f6298d2ce6a0b65742ac050685212eea8c5f83d48ea98b09c3928b16e36c7447a9551
diff --git a/sys-process/xjobs/files/search-libtinfo-for-tigetstr-and-tparm.patch b/sys-process/xjobs/files/search-libtinfo-for-tigetstr-and-tparm.patch
new file mode 100644
index 000000000000..e0600b0b7dc8
--- /dev/null
+++ b/sys-process/xjobs/files/search-libtinfo-for-tigetstr-and-tparm.patch
@@ -0,0 +1,32 @@
+From 8272978e3f90aec42101a6f254af779e20cfc0eb Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 14 Aug 2019 20:19:24 -0400
+Subject: [PATCH 1/1] Rename configure.in to configure.ac and search libtinfo
+ for tigetstr/tparm.
+
+---
+ configure.in => configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+ rename configure.in => configure.ac (95%)
+
+diff --git a/configure.in b/configure.ac
+similarity index 95%
+rename from configure.in
+rename to configure.ac
+index 21fc034..0baa3cc 100644
+--- a/configure.in
++++ b/configure.ac
+@@ -72,8 +72,8 @@ AC_CHECK_HEADER([term.h],
+ AC_INCLUDES_DEFAULT
+ )
+
+-AC_SEARCH_LIBS(tigetstr,ncurses,)
+-AC_SEARCH_LIBS(tparm,curses,)
++AC_SEARCH_LIBS(tigetstr,ncurses tinfo)
++AC_SEARCH_LIBS(tparm,curses tinfo)
+
+ AC_SUBST(DEBUG)
+ AC_SUBST(AUTOCONF)
+--
+2.21.0
+
diff --git a/sys-process/xjobs/xjobs-20190725.ebuild b/sys-process/xjobs/xjobs-20190725.ebuild
new file mode 100644
index 000000000000..9a5ad730ef3c
--- /dev/null
+++ b/sys-process/xjobs/xjobs-20190725.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Reads commands line by line and executes them in parallel"
+HOMEPAGE="http://www.maier-komor.de/xjobs.html"
+SRC_URI="http://www.maier-komor.de/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="sys-devel/flex"
+
+# The ncurses/terminfo libraries are used to provide color and status
+# support; but, they're detected and enabled automagically by the build
+# system. Thus it would do no good to hide them behind a USE flag that
+# can't be turned off.
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/search-libtinfo-for-tigetstr-and-tparm.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+}