summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Hamann <code@ares-macrotechnology.com>2020-12-22 09:43:57 +0100
committerPatrick McLean <chutzpah@gentoo.org>2020-12-31 12:17:37 -0800
commitb30cd2728c53d5d23ee5066381c5d6592503afce (patch)
tree310130020610d8bf5f4ce4adca3fb8e9d376b4f1 /sys-process
parentnet-misc/wget: Removed old (diff)
downloadgentoo-b30cd2728c53d5d23ee5066381c5d6592503afce.tar.gz
gentoo-b30cd2728c53d5d23ee5066381c5d6592503afce.tar.bz2
gentoo-b30cd2728c53d5d23ee5066381c5d6592503afce.zip
sys-process/bpytop: Install themes
Closes: https://bugs.gentoo.org/761223 Signed-off-by: Sebastian Hamann <code@ares-macrotechnology.com> Closes: https://github.com/gentoo/gentoo/pull/18760 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/bpytop/bpytop-1.0.52-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/bpytop/bpytop-1.0.52-r1.ebuild b/sys-process/bpytop/bpytop-1.0.52-r1.ebuild
new file mode 100644
index 000000000000..518430e585a1
--- /dev/null
+++ b/sys-process/bpytop/bpytop-1.0.52-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
+HOMEPAGE="https://github.com/aristocratos/bpytop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/bpytop-1.0.51-tests.patch"
+)
+
+src_install() {
+ insinto "/usr/share/${PN}/themes"
+ doins bpytop-themes/*.theme
+ distutils-r1_src_install
+}