summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-02-27 00:00:52 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-02-27 11:04:08 +0200
commitb995271380719cb19b36070412f1aa2ce9502505 (patch)
tree502f5a595aa8d2378d03b2cec4e0b4d7650d5e1f /sys-process
parentapp-misc/openrgb-plugin-visualmap: drop 0_p20211230 (diff)
downloadgentoo-b995271380719cb19b36070412f1aa2ce9502505.tar.gz
gentoo-b995271380719cb19b36070412f1aa2ce9502505.tar.bz2
gentoo-b995271380719cb19b36070412f1aa2ce9502505.zip
sys-process/fcron: drop 3.2.1-r8
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/Manifest1
-rw-r--r--sys-process/fcron/fcron-3.2.1-r8.ebuild266
2 files changed, 0 insertions, 267 deletions
diff --git a/sys-process/fcron/Manifest b/sys-process/fcron/Manifest
index 2740f599c094..3bb7eaf2f17e 100644
--- a/sys-process/fcron/Manifest
+++ b/sys-process/fcron/Manifest
@@ -1,2 +1 @@
-DIST fcron-3.2.1.src.tar.gz 601142 BLAKE2B 184b74f9d64186b7d3aae87d48ed0107525fd0c73bb8db86408bd246592ff4fbcbc04f8ca0064868a8555d7c6be2f183172d62daeed75275cd836517da504d0f SHA512 ddfd3e3a297b843c924aacccffaa5c1c6b300497f39daa1cdb90dc4cf4bc757042b0b2c1f055c119c8128c64d830ee0e8757091610432f5ffcacca25d369e5cd
DIST fcron-3.3.1.tar.gz 593688 BLAKE2B 5c2f91667c94fc9eae7ae014a7826ab1f26647a192425630dbdb84bbe3c9041be23a2a480eb13844dc18a5ba406fe77a157938af1e0343e5f9b0ce1a1405d66b SHA512 b9c5066bdf8588a6b8d811ccc0d49f1d41a17dabf898a280997a8136dc449c2a505c46868abf732f86184ff0720d51f17442691909acae8fb26edcd180cff281
diff --git a/sys-process/fcron/fcron-3.2.1-r8.ebuild b/sys-process/fcron/fcron-3.2.1-r8.ebuild
deleted file mode 100644
index cdf73c577fde..000000000000
--- a/sys-process/fcron/fcron-3.2.1-r8.ebuild
+++ /dev/null
@@ -1,266 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-WANT_AUTOMAKE="none"
-
-inherit autotools cron flag-o-matic pam systemd user-info
-
-DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
-HOMEPAGE="http://fcron.free.fr/"
-SRC_URI="http://fcron.free.fr/archives/${P}.src.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="audit debug pam selinux l10n_fr +mta +system-crontab readline"
-
-DEPEND="
- acct-group/fcron
- acct-user/fcron
- virtual/libcrypt:=
- audit? ( sys-process/audit )
- pam? ( sys-libs/pam )
- readline? ( sys-libs/readline:= )
- selinux? ( sys-libs/libselinux )
-"
-
-RDEPEND="
- ${DEPEND}
- app-misc/editor-wrapper
- mta? ( virtual/mta )
- pam? ( sys-auth/pambase )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.1-noreadline.patch
- "${FILESDIR}"/${PN}-3.2.1-configure-fix-audit-parameter-check.patch
- "${FILESDIR}"/${PN}-3.2.1-musl-getopt-order.patch
-)
-
-pkg_setup() {
- rootuser=$(egetent passwd 0 | cut -d ':' -f 1)
- [[ ${rootuser} ]] || rootuser=root
- rootgroup=$(egetent group 0 | cut -d ':' -f 1)
- [[ ${rootgroup} ]] || rootgroup=root
-}
-
-src_prepare() {
- default
-
- # respect LDFLAGS
- sed "s:\(@LIBS@\):\$(LDFLAGS) \1:" -i Makefile.in || die "sed failed"
-
- # Adjust fcrontab path
- sed -e 's:/etc/fcrontab:/etc/fcron/fcrontab:' -i script/check_system_crontabs.sh || die
-
- mv configure.in configure.ac || die
-
- cp "${FILESDIR}"/crontab.2 "${WORKDIR}"/crontab || die
-
- eautoconf
-}
-
-src_configure() {
- # Don't try to pass --with-debug as it'll play with cflags as
- # well, and run foreground which is a _very_ nasty idea for
- # Gentoo.
- use debug && append-cppflags -DDEBUG
-
- # bindir is used just for calling fcronsighup
- local myeconfargs=(
- --with-cflags="${CFLAGS}"
- --bindir=/usr/libexec
- --sbindir=/usr/libexec
- $(use_with audit)
- $(use_with mta sendmail)
- $(use_with pam)
- $(use_with readline)
- $(use_with selinux)
- --sysconfdir=/etc/fcron
- --with-username=fcron
- --with-groupname=fcron
- --with-piddir=/run
- --with-spooldir=/var/spool/fcron
- --with-fifodir=/run
- --with-fcrondyn=yes
- --disable-checks
- --with-editor=/usr/libexec/editor
- --with-shell=/bin/sh
- --without-db2man
- --without-dsssl-dir
- --with-rootname=${rootuser}
- --with-rootgroup=${rootgroup}
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- default
-
- # bug #216460
- sed \
- -e 's:/usr/local/etc/fcron:/etc/fcron/fcron:g' \
- -e 's:/usr/local/etc:/etc:g' \
- -e 's:/usr/local/:/usr/:g' \
- -i doc/*/*/*.{txt,1,5,8,html} \
- || die "unable to fix documentation references"
-}
-
-src_install() {
- keepdir /var/spool/fcron
-
- exeinto /usr/libexec
- doexe fcron fcronsighup
-
- dobin fcrondyn fcrontab
-
- insinto /etc/fcron
- doins files/fcron.{allow,deny,conf}
-
- if use system-crontab; then
- dosym fcrontab /usr/bin/crontab
-
- exeinto /usr/libexec
- newexe script/check_system_crontabs.sh check_system_crontabs
-
- insinto /etc/fcron
- newins "${FILESDIR}"/fcrontab.2 fcrontab
-
- fowners ${rootuser}:fcron /etc/fcron/fcrontab
- fperms 0640 /etc/fcron/fcrontab
-
- insinto /etc
- newins "${FILESDIR}"/crontab.2 crontab
- fi
-
- fowners fcron:fcron \
- /var/spool/fcron \
- /usr/bin/fcron{dyn,tab}
-
- # fcronsighup needs to be suid root, because it sends a HUP to the
- # running fcron daemon, but only has to be called by the fcron group
- # anyway
- fowners ${rootuser}:fcron \
- /usr/libexec/fcronsighup \
- /etc/fcron/fcron.{allow,deny,conf} \
- /etc/fcron
-
- fperms 6770 /var/spool/fcron
- fperms 6775 /usr/bin/fcron{dyn,tab}
-
- fperms 4710 /usr/libexec/fcronsighup
-
- fperms 0750 /etc/fcron
- fperms 0640 /etc/fcron/fcron.{allow,deny,conf}
-
- use pam && pamd_mimic system-services fcron auth account session
- cat > "${T}"/fcrontab.pam <<- EOF
- # Don't ask for the user's password; fcrontab will only allow to
- # change user if running as root.
- auth sufficient pam_permit.so
-
- # Still use the system-auth stack for account and session as the
- # sysadmin might have set up stuff properly, and also avoids
- # sidestepping limits (since fcrontab will run \$EDITOR).
- account include system-auth
- session include system-auth
- EOF
- use pam && newpamd "${T}"/fcrontab.pam fcrontab
-
- newinitd "${FILESDIR}"/fcron.init-r5 fcron
- systemd_newunit "${S}/script/fcron.init.systemd" fcron.service
-
- newconfd "${FILESDIR}"/fcron.confd fcron
-
- local DOCS=( MANIFEST VERSION "${WORKDIR}/crontab")
- DOCS+=( doc/en/txt/{readme,thanks,faq,todo,relnotes,changes}.txt )
-
- local HTML_DOCS=( doc/en/HTML/. )
-
- einstalldocs
-
- newdoc files/fcron.conf fcron.conf.sample
- doman doc/en/man/*.{1,5,8}
-
- for lang in fr; do
- use l10n_${lang} || continue
-
- doman -i18n=${lang} doc/${lang}/man/*.{1,5,8}
-
- docinto html/${lang}
- dodoc -r doc/${lang}/HTML/.
- done
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
- elog "Make sure you execute"
- elog ""
- elog " # emerge --config ${CATEGORY}/${PN}"
- elog ""
- elog "to install the default systab on this system."
- else
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "3.2.1" -gt ${v}; then
- # This is an upgrade
-
- elog "fcron's default systab was updated since your last installation."
- elog "You can use"
- elog ""
- elog " # emerge --config ${CATEGORY}/${PN}"
- elog ""
- elog "to re-install systab (do not call this command before you"
- elog "have merged your configuration files)."
-
- # Show this elog only once
- break
- fi
- done
- fi
-
- if ! use system-crontab; then
- echo ""
- ewarn "Remember that fcron will *not* use /etc/cron.d in this configuration"
- ewarn "due to USE=-system-crontab!"
- echo ""
- fi
-}
-
-pkg_config() {
- if [[ $(fcrontab -l -u systab 2>/dev/null) ]]; then
- eerror "We're not going to make any change to your systab as long as"
- eerror "it contains data; please clear it before proceeding."
- eerror "You can do that with"
- eerror ""
- eerror " # fcrontab -u systab -r"
- eerror ""
- eerror "However you are advised to do this by hand to review existing"
- eerror "systab just in case."
- return 1
- fi
-
- if use system-crontab; then
- elog "This is going to set up fcron to execute check_system_crontabs."
- elog "In this configuration, /etc/crontab and /etc/cron.d are respected."
- elog "Per default fcron will check for modifications every 10 minutes."
- /usr/libexec/check_system_crontabs -v -i -f
- else
- elog "This is going to set up fcron to set up a default systab that"
- elog "executes /etc/cron.{hourly,daily,weekly,monthly} but will ignore"
- elog "/etc/crontab and /etc/cron.d."
- fcrontab -u systab - <<- EOF
- !serial(true)
- 00 * * * * /bin/rm -f /var/spool/cron/lastrun/cron.hourly
- 00 00 * * * /bin/rm -f /var/spool/cron/lastrun/cron.daily
- 00 00 * * 6 /bin/rm -f /var/spool/cron/lastrun/cron.weekly
- 00 00 1 * * /bin/rm -f /var/spool/cron/lastrun/cron.monthly
- */10 * * * * /usr/bin/test -x /usr/sbin/run-crons && /usr/sbin/run-crons
- !serial(false)
- EOF
- fi
-}