summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-09 23:12:17 +0100
committerSam James <sam@gentoo.org>2022-10-10 00:10:07 +0100
commitbd2f623e04e69062fc4c0648def0fe266520f7f3 (patch)
treeca2805d6b13d582bb02836c06ae43ff53a419222 /sys-process
parentgnome-extra/gnome-boxes: Version bump to 43.0 (diff)
downloadgentoo-bd2f623e04e69062fc4c0648def0fe266520f7f3.tar.gz
gentoo-bd2f623e04e69062fc4c0648def0fe266520f7f3.tar.bz2
gentoo-bd2f623e04e69062fc4c0648def0fe266520f7f3.zip
sys-process/numactl: add 2.0.16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/Manifest1
-rw-r--r--sys-process/numactl/numactl-2.0.16.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-process/numactl/Manifest b/sys-process/numactl/Manifest
index 693f91b0dcda..291aeb4b2047 100644
--- a/sys-process/numactl/Manifest
+++ b/sys-process/numactl/Manifest
@@ -1 +1,2 @@
DIST numactl-2.0.14.tar.gz 439000 BLAKE2B 5f2abe25061ac29ecad8a6b24fe800d72c3538d9a155358f4b329ed1140053c7dbd93f01891904f76db94ed01113a34b4ebcbbf40e4060caf747958785ac9590 SHA512 28b95985d6b2f26c5f6f15fe235224c998c86f534adf5fdaa355a292cf2fd65515c91ba2a76c899d552d439b18ea1209a1712bd6755f8ee3a442f3935993b2e6
+DIST numactl-2.0.16.tar.gz 450003 BLAKE2B 3ac38129b914d62958182020f57969878f2817bd3155c6b5362a66f96deb2058268fa8004729a2d3333642c8c0bee73a451030a287958fa145247b7685e426aa SHA512 6e17724567c363a08994fe7f5569b6ec62bd1ae608244945fddcb2d6a212b08140340f0d862595ba4016fcba95193e851cb286798f685d314b4c72687af6d879
diff --git a/sys-process/numactl/numactl-2.0.16.ebuild b/sys-process/numactl/numactl-2.0.16.ebuild
new file mode 100644
index 000000000000..75c8f3695219
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.16.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="https://github.com/numactl/numactl"
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numactl/numactl.git"
+else
+ SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.14-numademo-cflags.patch # bug #540856
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # We need to copy the sources or else tests will fail
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ multilib_is_native_abi && default || emake libnuma.la
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi ; then
+ if [[ -d /sys/devices/system/node ]] ; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ emake regress2
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
+ find "${ED}"/usr/ -type f -name libnuma.la -delete || die
+}
+
+multilib_src_install_all() {
+ local DOCS=( README.md )
+ einstalldocs
+
+ # Delete man pages provided by the man-pages package, bug #238805
+ rm -r "${ED}"/usr/share/man/man[25] || die
+}