summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-07-26 00:29:11 -0700
committerZac Medico <zmedico@gentoo.org>2018-07-26 00:31:50 -0700
commitc03a6d641dd2dce29a98e0cdf6930ab4d3754232 (patch)
treeb5d71874967ba56d902e4da474abc41f0c86c097 /sys-process
parentmedia-libs/adplug: Remove old (diff)
downloadgentoo-c03a6d641dd2dce29a98e0cdf6930ab4d3754232.tar.gz
gentoo-c03a6d641dd2dce29a98e0cdf6930ab4d3754232.tar.bz2
gentoo-c03a6d641dd2dce29a98e0cdf6930ab4d3754232.zip
sys-process/tini: remove -Werror (bug 626438)
Fixes: https://bugs.gentoo.org/626438 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/tini/tini-0.18.0.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/sys-process/tini/tini-0.18.0.ebuild b/sys-process/tini/tini-0.18.0.ebuild
index 6055c7e98a14..9650f2b376b0 100644
--- a/sys-process/tini/tini-0.18.0.ebuild
+++ b/sys-process/tini/tini-0.18.0.ebuild
@@ -17,8 +17,20 @@ IUSE="+args +static"
src_prepare() {
cmake-utils_src_prepare
- # Do not strip binary
- sed -i -e 's/-Wl,-s")$/")/' \
+
+ local sed_args=(
+ # Do not strip binary
+ -e 's/-Wl,-s")$/")/'
+
+ # Remove -Werror and -pedantic-errors in order to allow macro
+ # redefinition, so that CFLAGS="-U_FORTIFY_SOURCE" does not
+ # trigger an error due to add_definitions(-D_FORTIFY_SOURCE=2)
+ # in CMakeLists.txt (bug 626438).
+ -e "s/ -Werror / /"
+ -e "s/ -pedantic-errors / /"
+ )
+
+ sed -i "${sed_args[@]}" \
-e "s/git.*status --porcelain.*/true/" \
-e "s/git.*log -n 1.*/true/" \
-e "s/git.\${tini_VERSION_GIT}/git.${GIT_COMMIT}/" \