summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2023-01-24 05:23:43 -0500
committerSam James <sam@gentoo.org>2023-02-04 22:49:44 +0000
commitd4a2e1576fa423a575a475dc2e24c37bdc75e6e3 (patch)
tree9c3ab7d43670051879d6b1944686322b8437116f /sys-process
parentgui-apps/waybar: include another patch for wireplumber (diff)
downloadgentoo-d4a2e1576fa423a575a475dc2e24c37bdc75e6e3.tar.gz
gentoo-d4a2e1576fa423a575a475dc2e24c37bdc75e6e3.tar.bz2
gentoo-d4a2e1576fa423a575a475dc2e24c37bdc75e6e3.zip
sys-process/iotop: add 0.6_p20230124
This bump fixes a lot of lingering issues as well as removing the need for patching. Moved to EAPI8 and PEP517. Closes: https://github.com/gentoo/gentoo/pull/24258 Closes: https://bugs.gentoo.org/815151 Co-authored-by: Sam James <sam@cmpct.info> Co-authored-by: Hairu/budgetazoo? Signed-off-by: Joe Kappus <joe@wt.gd> Closes: https://github.com/gentoo/gentoo/pull/29240 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop/Manifest1
-rw-r--r--sys-process/iotop/iotop-0.6_p20230124.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/iotop/Manifest b/sys-process/iotop/Manifest
index 962e9bd3da4f..9e9d839a5695 100644
--- a/sys-process/iotop/Manifest
+++ b/sys-process/iotop/Manifest
@@ -1 +1,2 @@
DIST iotop-0.6.tar.bz2 29779 BLAKE2B 6c979f7beef4e9ec6536eb5ec113ab7089ccb0b8b00dfca6181408390584dac0eae18b110c3f4837a25defd7ab2c2e9d79f1f5cad762f97519e94847951f0037 SHA512 b1047da3bc46604447cc8ab22442a3a5381e1a79a6b176fe9ee8402ee5cebb959205407a6aeaffccccde9d2f67624ff8ee6717b051838f13ab88bf3a16db3ab9
+DIST iotop-0.6_p20230124.tar.gz 28751 BLAKE2B 4fd281b663288825a3315442171df649b59a133479732367863e4f0d75f81e760af5117aec7b1ff070bb7a98e7348f76a6490b9ab8866c0ff7cb52073b07fbd8 SHA512 916809c9a97ed260525b00b4e6bd1f55f07b307bf1dc2f61e87317014d04e1bb3fab03c9ad9d5c110d198fbc89427cbe9e6679f03785f71e7e572f985dbac2a7
diff --git a/sys-process/iotop/iotop-0.6_p20230124.ebuild b/sys-process/iotop/iotop-0.6_p20230124.ebuild
new file mode 100644
index 000000000000..eaa314fde532
--- /dev/null
+++ b/sys-process/iotop/iotop-0.6_p20230124.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="ncurses(+)"
+
+MY_COMMIT="a14256a3ff74eeee59493ac088561f1bafab85a7"
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Top-like UI used to show which process is using the I/O"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+SRC_URI="https://repo.or.cz/iotop.git/snapshot/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT::7}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="!sys-process/iotop-c"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+DOCS=( NEWS README THANKS )
+
+pkg_postinst() {
+ ewarn "Since Linux 5.14, sysctl kernel.task_delayacct should be enabled"
+ ewarn "This can be enabled by running: 'sysctl kernel.task_delayacct=1' "
+ ewarn "And can be made persistent by adding 'kernel.task_delayacct = 1' to ${EROOT}/etc/sysctl.conf"
+}