summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-15 11:45:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-15 11:45:43 +0200
commitf01e946e5b383a8a8af139e11a3141b4d15b7079 (patch)
tree03fab38236449123032d5889b7a3cfcd00793a42 /sys-process
parentwww-misc/urlwatch: fix test dependencies, re-add pycodestyle (diff)
downloadgentoo-f01e946e5b383a8a8af139e11a3141b4d15b7079.tar.gz
gentoo-f01e946e5b383a8a8af139e11a3141b4d15b7079.tar.bz2
gentoo-f01e946e5b383a8a8af139e11a3141b4d15b7079.zip
sys-process/htop: Bump to version 3.0.2
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/Manifest1
-rw-r--r--sys-process/htop/htop-3.0.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index f982a8f1b043..af4e1b9b7787 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1,3 +1,4 @@
DIST htop-2.2.0.tar.gz 308109 BLAKE2B 323a3bfe5032b6d59a3f751831a2af6aa7ae7e9ecceb35828812cb375d919de51f401ffe59fffdfc83a72c8dace879c5d5a0e857511c20e2126d11cdc4101b0b SHA512 ec1335bf0e3e0387e5e50acbc508d0effad19c4bc1ac312419dc97b82901f4819600d6f87a91668f39d429536d17304d4b14634426a06bec2ecd09df24adc62e
DIST htop-3.0.0.tar.gz 179371 BLAKE2B 7501d8277eb97e39f7a8e2e9191bdde97deca6f3240a3e497ce55e71b0659122223356d4ff03086f9303b82ea4de0fa4e7909baca6de063ac6b22d7b6530f9be SHA512 36dc37b416b9917005007448fe73fdd6475a3f7f8442a083923d3f5dfb706d0f1731255522a99b67cc547b239acb1c68b144f8d600e243eeba160b2a43e8339a
DIST htop-3.0.1.tar.gz 179925 BLAKE2B d722bc49d7b546aec1359a5dc838e0f6cc4b17f8d2d2c59fd7fbeaf827233f658ea819f4c69832af5cfd4f836d3d66c223a9580037cf8d6d2ae28c6a6b3499b5 SHA512 0d6a1b0839a94f01429c85a459b0c6439051d1b6e69bf77c6b3bb31c81902a3127936ab9adc5bf1807f4b3d7b10a177a89fb9b883931f8dcf828ed06727d6945
+DIST htop-3.0.2.tar.gz 176132 BLAKE2B 9abc28461d346eeac7f9741bc1ba08c898d00be013abce972be4370b9b35d92661fcb4521fa715bc779c1c9b56bc3c0eeb5375c0df8ec7585df3774ac67ca504 SHA512 5b578972e40e3229aa8b2bdc931c4c8bceaafd2a150b02e0257ab35a4fbac25852e959ecc472bd6747be57ea8734b59cc4b872a5ac829624cc80e1722c54d868
diff --git a/sys-process/htop/htop-3.0.2.ebuild b/sys-process/htop/htop-3.0.2.ebuild
new file mode 100644
index 000000000000..eacb7a88db21
--- /dev/null
+++ b/sys-process/htop/htop-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools linux-info python-any-r1
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
+SRC_URI="https://github.com/htop-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="sys-libs/ncurses:0=[unicode?]"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+PATCHES=()
+
+pkg_setup() {
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop (what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ local myeconfargs=(
+ # fails to build against recent hwloc versions
+ --disable-hwloc
+ --enable-taskstats
+ $(use_enable kernel_linux cgroup)
+ $(use_enable kernel_linux linux-affinity)
+ $(use_enable openvz)
+ $(use_enable unicode)
+ $(use_enable vserver)
+ )
+ econf ${myeconfargs[@]}
+}