summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /virtual/jdk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'virtual/jdk')
-rw-r--r--virtual/jdk/jdk-1.6.0-r2.ebuild30
-rw-r--r--virtual/jdk/jdk-1.7.0.ebuild16
-rw-r--r--virtual/jdk/jdk-1.8.0.ebuild13
-rw-r--r--virtual/jdk/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/virtual/jdk/jdk-1.6.0-r2.ebuild b/virtual/jdk/jdk-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..72ad49cca1ce
--- /dev/null
+++ b/virtual/jdk/jdk-1.6.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Virtual for Java Development Kit (JDK)"
+SLOT="1.6"
+KEYWORDS="amd64 ppc ppc64 x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+# The keyword voodoo below is needed to work around confilcting masking types
+# and for having arch specific preferences.
+# All VMs must be listed in the no use flag enabled case which reflects the
+# default order for amd64 and x86.
+
+# This is that ppc(64) users will get a masked license warning for ibm-jdk-bin
+# instead of (not useful) missing keyword warning for sun-jdk. #287615
+PPC_OPTS="|| (
+ =dev-java/ibm-jdk-bin-1.6.0*
+ =dev-java/icedtea-6* )"
+
+RDEPEND="|| (
+ ppc? ( ${PPC_OPTS} )
+ ppc64? ( ${PPC_OPTS} )
+ =dev-java/icedtea-bin-6*
+ =dev-java/icedtea-6*
+ =dev-java/ibm-jdk-bin-1.6.0*
+ =dev-java/hp-jdk-bin-1.6.0*
+ =dev-java/soylatte-jdk-bin-1.0*
+ =dev-java/apple-jdk-bin-1.6.0* )"
diff --git a/virtual/jdk/jdk-1.7.0.ebuild b/virtual/jdk/jdk-1.7.0.ebuild
new file mode 100644
index 000000000000..004d1c3b7654
--- /dev/null
+++ b/virtual/jdk/jdk-1.7.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Virtual for Java Development Kit (JDK)"
+SLOT="1.7"
+KEYWORDS="amd64 ~arm ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="|| (
+ =dev-java/icedtea-bin-7*
+ =dev-java/icedtea-7*
+ =dev-java/oracle-jdk-bin-1.7.0*
+ =dev-java/soylatte-jdk-bin-7*
+ )"
diff --git a/virtual/jdk/jdk-1.8.0.ebuild b/virtual/jdk/jdk-1.8.0.ebuild
new file mode 100644
index 000000000000..07bf6b6f48d6
--- /dev/null
+++ b/virtual/jdk/jdk-1.8.0.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Virtual for Java Development Kit (JDK)"
+SLOT="1.8"
+# TODO: Temporarily dropped ~sparc-solaris and ~x86-solaris as oracle-jdk-bin
+# no longer provides them. Also temporarily dropped ~ia64.
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
+
+RDEPEND="=dev-java/oracle-jdk-bin-1.8.0*"
diff --git a/virtual/jdk/metadata.xml b/virtual/jdk/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/virtual/jdk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>