summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-01-12 10:19:18 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-01-12 10:19:18 -0500
commitf63c8955c91f699f8484612cf33ae4f789c96a77 (patch)
tree960de5a7015dfa0ce8a41539f8c9b5ac8509c005 /virtual/libelf/libelf-3.ebuild
parentprofiles: mask future >virtual/libelf-2 on musl and uclibc-ng (diff)
downloadgentoo-f63c8955c91f699f8484612cf33ae4f789c96a77.tar.gz
gentoo-f63c8955c91f699f8484612cf33ae4f789c96a77.tar.bz2
gentoo-f63c8955c91f699f8484612cf33ae4f789c96a77.zip
virtual/libelf: split the virtual in two for different sonames, bug #643802
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'virtual/libelf/libelf-3.ebuild')
-rw-r--r--virtual/libelf/libelf-3.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/virtual/libelf/libelf-3.ebuild b/virtual/libelf/libelf-3.ebuild
new file mode 100644
index 000000000000..82c100cbdb56
--- /dev/null
+++ b/virtual/libelf/libelf-3.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for libelf.so.1 provider dev-libs/elfutils"
+SLOT="0/1"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+
+RDEPEND="
+ || (
+ >=dev-libs/elfutils-0.155-r1:0/0[${MULTILIB_USEDEP}]
+ >=sys-freebsd/freebsd-lib-9.2_rc1[${MULTILIB_USEDEP}]
+ )"