summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-10 10:05:46 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-10 11:54:09 +0100
commit8fa74ddf233bd9e8b80e908e27cb7ad1dea05864 (patch)
treefaa53c57af1495ce6d1f0ecbd439b963b7f43034 /virtual/python-asyncio/python-asyncio-0.ebuild
parentvirtual/python-futures: Keyword under ALLARCHES policy (diff)
downloadgentoo-8fa74ddf233bd9e8b80e908e27cb7ad1dea05864.tar.gz
gentoo-8fa74ddf233bd9e8b80e908e27cb7ad1dea05864.tar.bz2
gentoo-8fa74ddf233bd9e8b80e908e27cb7ad1dea05864.zip
virtual/python-asyncio: Add new virtual
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual/python-asyncio/python-asyncio-0.ebuild')
-rw-r--r--virtual/python-asyncio/python-asyncio-0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/python-asyncio/python-asyncio-0.ebuild b/virtual/python-asyncio/python-asyncio-0.ebuild
new file mode 100644
index 000000000000..b716210e5d84
--- /dev/null
+++ b/virtual/python-asyncio/python-asyncio-0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python 3.4+ asyncio module"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/asyncio[${PYTHON_USEDEP}]' python3_3)"