summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-10 10:55:04 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-10 11:54:09 +0100
commitad4624630352b6a72088933f249200156199b3e5 (patch)
tree99ce6eb42c4e52a3928c339a2761af3a3b4aa56e /virtual/python-backports_abc/python-backports_abc-0.ebuild
parentvirtual/python-futures: Add python3.5 support (diff)
downloadgentoo-ad4624630352b6a72088933f249200156199b3e5.tar.gz
gentoo-ad4624630352b6a72088933f249200156199b3e5.tar.bz2
gentoo-ad4624630352b6a72088933f249200156199b3e5.zip
virtual/python-backports_abc: Add new virtual to support mixed module states
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual/python-backports_abc/python-backports_abc-0.ebuild')
-rw-r--r--virtual/python-backports_abc/python-backports_abc-0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/python-backports_abc/python-backports_abc-0.ebuild b/virtual/python-backports_abc/python-backports_abc-0.ebuild
new file mode 100644
index 000000000000..4ef0fd7a7e53
--- /dev/null
+++ b/virtual/python-backports_abc/python-backports_abc-0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python 3.3+ collections.abc module"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/backports-abc[${PYTHON_USEDEP}]' python3_3)"