summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-01 14:12:39 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-01 14:24:39 -0700
commit4472b5830b3716ae519c16373bb20f0e095c9171 (patch)
tree9eaf6c708102249a1a6b6ad9db97b904ecceba5e /virtual/rust/rust-1.56.1.ebuild
parentdev-lang/rust: add 1.56.1 (diff)
downloadgentoo-4472b5830b3716ae519c16373bb20f0e095c9171.tar.gz
gentoo-4472b5830b3716ae519c16373bb20f0e095c9171.tar.bz2
gentoo-4472b5830b3716ae519c16373bb20f0e095c9171.zip
virtual/rust: add 1.56.1
Bug: https://bugs.gentoo.org/821157 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'virtual/rust/rust-1.56.1.ebuild')
-rw-r--r--virtual/rust/rust-1.56.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.56.1.ebuild b/virtual/rust/rust-1.56.1.ebuild
new file mode 100644
index 000000000000..f9d87cdb210c
--- /dev/null
+++ b/virtual/rust/rust-1.56.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"