summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-09-29 16:49:40 +0530
committerWANG Xuerui <xen0n@gentoo.org>2023-10-02 16:09:09 +0800
commitb5e1feb40f6a9673c4ea132819861facb3f8149c (patch)
treeef0d9fd050dac992d933b26933448dc3dd251264 /virtual/rust/rust-1.66.1-r1.ebuild
parentdev-lang/rust: Fix build with musl 1.2.4 (diff)
downloadgentoo-b5e1feb40f6a9673c4ea132819861facb3f8149c.tar.gz
gentoo-b5e1feb40f6a9673c4ea132819861facb3f8149c.tar.bz2
gentoo-b5e1feb40f6a9673c4ea132819861facb3f8149c.zip
virtual/rust: default to rust-bin
Prefer dev-lang/rust-bin over dev-lang/rust. Keeps it consistent with virtual/{jre,jdk}. Prevent long compile times when some dependency unknowingly pulls in rust. Imagine new user (unaware of rust-bin) wanting simple app-crypt/certbot or app-admin/ansible-core but having to compile whole rust for that. Because dep graph goes like app-admin/ansible-core -> dev-python/cryptography -> virtual/rust -> dev-lang/rust [xen0n: revbumped everything for correct static dep operation] Closes: https://github.com/gentoo/gentoo/pull/33121 Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'virtual/rust/rust-1.66.1-r1.ebuild')
-rw-r--r--virtual/rust/rust-1.66.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.66.1-r1.ebuild b/virtual/rust/rust-1.66.1-r1.ebuild
new file mode 100644
index 000000000000..006314ee8c24
--- /dev/null
+++ b/virtual/rust/rust-1.66.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-15"
+KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"