summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-03-23 16:22:34 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-03-23 16:24:18 -0700
commitb6242bb737ea16d6e57ca68d732371854abc5f54 (patch)
tree7882757de4f5d1f9ec9826b943bb61bb183916e5 /virtual
parentdev-lang/rust-bin: revbump 1.67.1, depend on gcc for libgcc_s (diff)
downloadgentoo-b6242bb737ea16d6e57ca68d732371854abc5f54.tar.gz
gentoo-b6242bb737ea16d6e57ca68d732371854abc5f54.tar.bz2
gentoo-b6242bb737ea16d6e57ca68d732371854abc5f54.zip
virtual/rust: add 1.68.1
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/rust/rust-1.68.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.68.1.ebuild b/virtual/rust/rust-1.68.1.ebuild
new file mode 100644
index 000000000000..ae12ed9a2d0f
--- /dev/null
+++ b/virtual/rust/rust-1.68.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-15"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"